X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 57 Won't Open on Windows 10 Creator Update

Posted

After updating to Firefox 57 on a relative's laptop they've been getting an intermittent problem where Firefox will not open and I'll have to re-install it, it in order for it to work.

The issue is very random, when it first started happening about 2 months ago, my first thought was to see what's running in Task Manager, the "firefox.ex"e service was running no problem, so I killed it, and tried to open up Firefox again. The service starts in Task Manager but the actual program doesn't load. I tried the same thing with admin privileges, same result. I tried opening it in Safe Mode, same thing.

The only thing to do was a re-install, so I did that and it worked for a bit. After sometimes a few days, sometimes only a few hours, the problem was back. I did a 100% clean install of Firefox and the same thing happens.

I even formatted the hard drive and did a clean install of Windows and re-installed Firefox, it worked, for a few weeks and now its doing it again. There is no rhyme or reason as to why it happens, it seems completely random.

I've searched around and no one seems to have this same exact issue, any ideas what's causing this nuisance?

After updating to Firefox 57 on a relative's laptop they've been getting an intermittent problem where Firefox will not open and I'll have to re-install it, it in order for it to work. The issue is very random, when it first started happening about 2 months ago, my first thought was to see what's running in Task Manager, the "firefox.ex"e service was running no problem, so I killed it, and tried to open up Firefox again. The service starts in Task Manager but the actual program doesn't load. I tried the same thing with admin privileges, same result. I tried opening it in Safe Mode, same thing. The only thing to do was a re-install, so I did that and it worked for a bit. After sometimes a few days, sometimes only a few hours, the problem was back. I did a 100% clean install of Firefox and the same thing happens. I even formatted the hard drive and did a clean install of Windows and re-installed Firefox, it worked, for a few weeks and now its doing it again. There is no rhyme or reason as to why it happens, it seems completely random. I've searched around and no one seems to have this same exact issue, any ideas what's causing this nuisance?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 28.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:57.0) Gecko/20100101 Firefox/57.0

More Information

WestEnd
  • Top 10 Contributor
51 solutions 2468 answers

Helpful Reply

What O/S version do you have x86 or x64? And what FF version are you trying to install x86 or x64?

What O/S version do you have x86 or x64? And what FF version are you trying to install x86 or x64?

Question owner

WestEnd said

What O/S version do you have x86 or x64? And what FF version are you trying to install x86 or x64?

Its x64 Windows 10 and x64 FF.

I just tired to manually select x86 FF to install and instead it automatically overrode my decision and didn't tell me and installed x64 again.

''WestEnd [[#answer-1062898|said]]'' <blockquote> What O/S version do you have x86 or x64? And what FF version are you trying to install x86 or x64? </blockquote> Its x64 Windows 10 and x64 FF. I just tired to manually select x86 FF to install and instead it automatically overrode my decision and didn't tell me and installed x64 again.
Pkshadow
  • Top 10 Contributor
917 solutions 11988 answers

This will get you the 32 if that is what you want : Current Release Firefox 57.0.4 with a Full Version Installer

If still have issues Should do it this : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 57.0.4 with a Full Version Installer

Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

Monitor in Task Manager. Should stay below 2 gigs. If excessive then do below and monitor and change if need to...Test and go up again , go back down, it will eventually get a zone you and it can live with.

Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please.

Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on.

Please let us know if this solved your issue or if need further assistance.

This will get you the 32 if that is what you want : Current Release Firefox 57.0.4 with a Full Version Installer *https://www.mozilla.org/firefox/all/ If still have issues Should do it this : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Reinstall with Current Release Firefox 57.0.4 with a Full Version Installer *https://www.mozilla.org/firefox/all/ Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser. Monitor in Task Manager. Should stay below 2 gigs. If excessive then do below and monitor and change if need to...Test and go up again , go back down, it will eventually get a zone you and it can live with. Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on. Please let us know if this solved your issue or if need further assistance.