X
Tap here to go to the mobile version of the site.

Support Forum

Getting error SSL_ERROR_NO_CYPHER_OVERLAP when using Parallels Remote Application Server

Posted

After setting up Parallels Remote Application Server, we are not able to connect using Firefox v54.0.

Message received: Error code: SSL_ERROR_NO_CYPHER_OVERLAP

Product page: http://www.parallels.com/products/ras/remote-application-server/

When setting security to "medium", Firefox works great. We are using "high" security however and so it only works in Edge, chrome, and IE11. We would really like for this to work in the current version of Firefox (note, have not tested older releases).

After looking at this page:

http://kb.parallels.com/en/123007

It is unclear to me whether we can make any changes to the product to get it working with Firefox while maintaining high security. Making changes to Firefox isn't an option since this product is used in a BYOD scenario and we won't be making or recommending config changes to user's browsers if there are others that work out of the box.

After setting up Parallels Remote Application Server, we are not able to connect using Firefox v54.0. Message received: Error code: SSL_ERROR_NO_CYPHER_OVERLAP Product page: http://www.parallels.com/products/ras/remote-application-server/ When setting security to "medium", Firefox works great. We are using "high" security however and so it only works in Edge, chrome, and IE11. We would really like for this to work in the current version of Firefox (note, have not tested older releases). After looking at this page: http://kb.parallels.com/en/123007 It is unclear to me whether we can make any changes to the product to get it working with Firefox while maintaining high security. Making changes to Firefox isn't an option since this product is used in a BYOD scenario and we won't be making or recommending config changes to user's browsers if there are others that work out of the box.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36 Edge/15.15063

More Information

FredMcD
  • Top 10 Contributor
3585 solutions 48834 answers

SSL_ERROR_NO_CYPHER_OVERLAP Your server apparently doesn't offer any cipher suites necessary to establish a secure https connection that are supported in Firefox. You can check what kind of cipher suites Firefox can make use of by visiting https://www.ssllabs.com/ssltest/viewMyClient.html

SSL_ERROR_NO_CYPHER_OVERLAP Your server apparently doesn't offer any cipher suites necessary to establish a secure https connection that are supported in Firefox. You can check what kind of cipher suites Firefox can make use of by visiting https://www.ssllabs.com/ssltest/viewMyClient.html
cor-el
  • Top 10 Contributor
  • Moderator
16226 solutions 146494 answers

You did make sure that TLS 1.2 is enabled in Firefox?

You can check the TLS settings prefs on the about:config page

  • security.tls.version.min
  • security.tls.version.max
  • 1 means TLS 1.0; 2 means TLS 1.1; 3 means TLS 1.2; 4 means TLS 1.3;
You did make sure that TLS 1.2 is enabled in Firefox? You can check the TLS settings prefs on the about:config page *security.tls.version.min *security.tls.version.max *1 means TLS 1.0; 2 means TLS 1.1; 3 means TLS 1.2; 4 means TLS 1.3; *http://kb.mozillazine.org/security.tls.version.*

Helpful Reply

FredMcD said

SSL_ERROR_NO_CYPHER_OVERLAP Your server apparently doesn't offer any cipher suites necessary to establish a secure https connection that are supported in Firefox. You can check what kind of cipher suites Firefox can make use of by visiting https://www.ssllabs.com/ssltest/viewMyClient.html

Thank you for the link, this will be helpful.

''FredMcD [[#answer-982781|said]]'' <blockquote> SSL_ERROR_NO_CYPHER_OVERLAP Your server apparently doesn't offer any cipher suites necessary to establish a secure https connection that are supported in Firefox. You can check what kind of cipher suites Firefox can make use of by visiting https://www.ssllabs.com/ssltest/viewMyClient.html </blockquote> Thank you for the link, this will be helpful.

Question owner

cor-el said

You did make sure that TLS 1.2 is enabled in Firefox? You can check the TLS settings prefs on the about:config page
  • security.tls.version.min
  • security.tls.version.max
  • 1 means TLS 1.0; 2 means TLS 1.1; 3 means TLS 1.2; 4 means TLS 1.3;

Yep. Using default settings and TLS 1.2 is enabled. Problem appears to be cipher settings. I'm just a little shocked that the default high security setting from Parallels wasn't tested apparently in Firefox.

''cor-el [[#answer-982897|said]]'' <blockquote> You did make sure that TLS 1.2 is enabled in Firefox? You can check the TLS settings prefs on the about:config page *security.tls.version.min *security.tls.version.max *1 means TLS 1.0; 2 means TLS 1.1; 3 means TLS 1.2; 4 means TLS 1.3; *http://kb.mozillazine.org/security.tls.version.* </blockquote> Yep. Using default settings and TLS 1.2 is enabled. Problem appears to be cipher settings. I'm just a little shocked that the default high security setting from Parallels wasn't tested apparently in Firefox.