Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

You need to do something about the ridiculous TLS Secure Connections pop-ups! I even get them when I'm directly on your site!

  • 3 replies
  • 1 has this problem
  • 13 views
  • Last reply by cor-el

more options

Problem is in the title...I can't get anywhere without the ridiculous pop-up coming up and interfering with my links. It's terrible to have it happen when I'm in the middle of an authentic payment transaction...It happens even on sites that have to have legit and updated TLS such as PayPal, Amazon, Google, Bank of America, Twitter, and yes, even YOU. I have it captured on a screenshot so if there's a way, I can send it to you.


Everything I use is updated. MacBook Pro 17" OS X 10.8.5 Firefox 42.0


edited email from public and spambots.

Modified by James

All Replies (3)

more options

Can you attach a screenshot?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB
more options

Attached screenshot.

more options

If you can't inspect the certificate via "I Understand the Risks" then try this:

Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field of this window type or paste the URL of the website.

  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer

You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer with the issuer.