Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to add a password to a website initailly labelled never ask, but is not showing in the exceptions area to remove from exceptions (the exceptions is empty)

  • 2 replies
  • 1 has this problem
  • 10 views
  • Last reply by cor-el

more options

I'm trying to have Firefox remember a password to a website I initially marked "never ask", but I cannot remove it from the "exceptions" area because nothing shows in the exceptions area. can this be resolved?

Also, I am unable to edit passwords in the saved passwords area. Where are saved passwords edited?

Chosen solution

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.


Clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, passwords, and other website specific data.

Read this answer in context 👍 0

All Replies (2)

more options

Try using the Permissions Manager. In the address bar, type or paste about:permissions and press Enter. In the left column, sites will gradually appear. To filter the list, type part of the site name in the search box above the list. Click the site that has the problem, and on the right side, you can change the Store Passwords permission from Block to Allow.

Of course, if it's already Allow, hmm, the "don't bother me" must be stored somewhere else. Perhaps if you toggle this setting to block and then back to allow Firefox will ask again???

more options

Chosen Solution

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.


Clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, passwords, and other website specific data.