X
Tap here to go to the mobile version of the site.

Support Forum

Proxy Settings No Longer Work with v32.0.3

Posted

The manual proxy settings no longer work for me with v32.0.3 Windows 32-bit version. I have tried disabling all add-ons, resetting everything, and removing then reinstalling.

Anything else I can try?

The manual proxy settings no longer work for me with v32.0.3 Windows 32-bit version. I have tried disabling all add-ons, resetting everything, and removing then reinstalling. Anything else I can try?

Chosen solution

Thank you for the help. My firewall on the effected Mac was off before/after the updates. So playing around with the firewall settings didn't help.

I tried again fidget around with the add-ons. Disabling DoNotTrackMe (v.4.0.1249) fixed the problem. Enabling it again brings back the issue.

Read this answer in context 4

Additional System Details

Installed Plug-ins

  • Shockwave Flash 15.0 r0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.8
  • Google Update
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:32.0) Gecko/20100101 Firefox/32.0

More Information

FredMcD
  • Top 10 Contributor
4261 solutions 59654 answers

If you are not using a proxy, set the proxy option to none.

If you are not using a proxy, set the proxy option to none.

Question owner

I am trying to use a proxy.

I am trying to use a proxy.
FredMcD
  • Top 10 Contributor
4261 solutions 59654 answers

Okay, what do you mean by; proxy settings no longer work

What happens, and not happen?

Are the settings correct? Are the settings changing?

Okay, what do you mean by; '' proxy settings no longer work'' What happens, and not happen? Are the settings correct? Are the settings changing?

Question owner

I mean that they no longer have any affect whatsoever.

Nothing happens. Firefox behaves as if it is not configured to use a proxy. It bypasses those settings completely, as if Firefox does not have the ability to use a proxy.

Yes, the proxy settings are correct. Or at least they are in the GUI where I put them; I have no idea if something in Firefox beyond the GUI is not correct. They are the same settings that I have been using for years. Are they changing, you ask? Only if I change them myself.

I mean that they no longer have any affect whatsoever. Nothing happens. Firefox behaves as if it is not configured to use a proxy. It bypasses those settings completely, as if Firefox does not have the ability to use a proxy. Yes, the proxy settings are correct. Or at least they are in the GUI where I put them; I have no idea if something in Firefox beyond the GUI is not correct. They are the same settings that I have been using for years. Are they changing, you ask? Only if I change them myself.

Question owner

Here's an example: I have manually configured Firefox to use a random port. I have randomly chosen 42658, and I have checked the box "Use this proxy server for all protocols".

I am currently using this setting, so Firefox be directed to that port.

Except I do not have a proxy at that port. Yet I am able to send this message right now. This message should not have been sent, and you should not be seeing it now.

Here's an example: I have manually configured Firefox to use a random port. I have randomly chosen 42658, and I have checked the box "Use this proxy server for all protocols". I am currently using this setting, so Firefox be directed to that port. Except I do not have a proxy at that port. Yet I am able to send this message right now. This message should not have been sent, and you should not be seeing it now.
FredMcD
  • Top 10 Contributor
4261 solutions 59654 answers

Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Then in the reply box at the bottom of this page, do a right click in the box and select Paste. This will show us your system details. No Personal Information Is Collected.

Type '''about:support''' in the address bar and press '''Enter.''' Under the main banner, press the button; '''Copy Text To Clipboard.'''. Then in the reply box at the bottom of this page, do a right click in the box and select '''Paste.''' This will show us your system details. '''No Personal Information Is Collected.'''
yoshipop 1 solutions 4 answers

My problem is exactly as described by NWTSCL (10/2/14 8:33 AM POST).

The problem occurred immediately after I updated to Mac Version 33.0.2 from 32.0.3.

I did confirm the proxy settings under about:config which are consistent with those in GUI setup. I also doubled-checked that the proxy server is up and running using another Mac client with earlier version FireFox.

Here's my about:support main page data:

Application Basics


Name: Firefox Version: 33.0.2 User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:33.0) Gecko/20100101 Firefox/33.0 Multiprocess Windows: 0/10

Crash Reports for the Last 3 Days


All Crash Reports

Extensions


Name: DoNotTrackMe: Online Privacy Protection Version: 4.0.1249 Enabled: true ID: donottrackplus@abine.com

Name: Lightbeam Version: 1.0.10.2 Enabled: true ID: jid1-F9UJ2thwoAm5gQ@jetpack

Graphics


Device ID: 0x 126 GPU Accelerated Windows: 10/10 OpenGL (OMTC) Vendor ID: 0x8086 WebGL Renderer: Intel Inc. -- Intel HD Graphics 3000 OpenGL Engine windowLayerManagerRemote: true AzureCanvasBackend: quartz AzureContentBackend: quartz AzureFallbackCanvasBackend: none AzureSkiaAccelerated: 0

Important Modified Preferences


accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.capacity: 358400 browser.cache.disk.smart_size_cached_value: 358400 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.frecency_experiment: 1 browser.places.smartBookmarksVersion: 7 browser.sessionstore.upgradeBackup.latestBuildID: 20141027150301 browser.startup.homepage: about:home browser.startup.homepage_override.buildID: 20141027150301 browser.startup.homepage_override.mstone: 33.0.2 dom.mozApps.used: true extensions.lastAppVersion: 33.0.2 font.internaluseonly.changed: true gfx.blacklist.webgl.msaa: 4 media.gmp-gmpopenh264.lastUpdate: 1414896787 media.gmp-gmpopenh264.version: 1.1 media.gmp-manager.lastCheck: 1414896787 network.cookie.cookieBehavior: 1 network.cookie.prefsMigrated: true places.database.lastMaintenance: 1414929337 places.history.expiration.transient_current_max_pages: 104858 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true print.print_bgcolor: false print.print_bgimages: false print.print_colorspace: print.print_command: print.print_downloadfonts: false print.print_duplex: 0 print.print_evenpages: true print.print_in_color: true print.print_margin_bottom: 0.5 print.print_margin_left: 0.5 print.print_margin_right: 0.5 print.print_margin_top: 0.5 print.print_oddpages: true print.print_orientation: 0 print.print_page_delay: 50 print.print_paper_data: 0 print.print_paper_height: 11.00 print.print_paper_name: print.print_paper_size_type: 1 print.print_paper_size_unit: 0 print.print_paper_width: 8.50 print.print_plex_name: print.print_resolution: 0 print.print_resolution_name: print.print_reversed: false print.print_scaling: 1.00 print.print_shrink_to_fit: true print.print_to_file: false print.print_unwriteable_margin_bottom: 56 print.print_unwriteable_margin_left: 25 print.print_unwriteable_margin_right: 25 print.print_unwriteable_margin_top: 25 privacy.sanitize.migrateFx3Prefs: true storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1412881915

Important Locked Preferences


JavaScript


Incremental GC: true

Accessibility


Activated: false Prevent Accessibility: 0

Library Versions


NSPR Expected minimum version: 4.10.7 Version in use: 4.10.7

NSS Expected minimum version: 3.17.1 Basic ECC Version in use: 3.17.1 Basic ECC

NSSSMIME Expected minimum version: 3.17.1 Basic ECC Version in use: 3.17.1 Basic ECC

NSSSSL Expected minimum version: 3.17.1 Basic ECC Version in use: 3.17.1 Basic ECC

NSSUTIL Expected minimum version: 3.17.1 Version in use: 3.17.1

Experimental Features


My problem is exactly as described by NWTSCL (10/2/14 8:33 AM POST). The problem occurred immediately after I updated to Mac Version 33.0.2 from 32.0.3. I did confirm the proxy settings under '''about:config''' which are consistent with those in GUI setup. I also doubled-checked that the proxy server is up and running using another Mac client with earlier version FireFox. Here's my '''about:support''' main page data: Application Basics ------------------ Name: Firefox Version: 33.0.2 User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:33.0) Gecko/20100101 Firefox/33.0 Multiprocess Windows: 0/10 Crash Reports for the Last 3 Days --------------------------------- All Crash Reports Extensions ---------- Name: DoNotTrackMe: Online Privacy Protection Version: 4.0.1249 Enabled: true ID: donottrackplus@abine.com Name: Lightbeam Version: 1.0.10.2 Enabled: true ID: jid1-F9UJ2thwoAm5gQ@jetpack Graphics -------- Device ID: 0x 126 GPU Accelerated Windows: 10/10 OpenGL (OMTC) Vendor ID: 0x8086 WebGL Renderer: Intel Inc. -- Intel HD Graphics 3000 OpenGL Engine windowLayerManagerRemote: true AzureCanvasBackend: quartz AzureContentBackend: quartz AzureFallbackCanvasBackend: none AzureSkiaAccelerated: 0 Important Modified Preferences ------------------------------ accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.capacity: 358400 browser.cache.disk.smart_size_cached_value: 358400 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.frecency_experiment: 1 browser.places.smartBookmarksVersion: 7 browser.sessionstore.upgradeBackup.latestBuildID: 20141027150301 browser.startup.homepage: about:home browser.startup.homepage_override.buildID: 20141027150301 browser.startup.homepage_override.mstone: 33.0.2 dom.mozApps.used: true extensions.lastAppVersion: 33.0.2 font.internaluseonly.changed: true gfx.blacklist.webgl.msaa: 4 media.gmp-gmpopenh264.lastUpdate: 1414896787 media.gmp-gmpopenh264.version: 1.1 media.gmp-manager.lastCheck: 1414896787 network.cookie.cookieBehavior: 1 network.cookie.prefsMigrated: true places.database.lastMaintenance: 1414929337 places.history.expiration.transient_current_max_pages: 104858 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true print.print_bgcolor: false print.print_bgimages: false print.print_colorspace: print.print_command: print.print_downloadfonts: false print.print_duplex: 0 print.print_evenpages: true print.print_in_color: true print.print_margin_bottom: 0.5 print.print_margin_left: 0.5 print.print_margin_right: 0.5 print.print_margin_top: 0.5 print.print_oddpages: true print.print_orientation: 0 print.print_page_delay: 50 print.print_paper_data: 0 print.print_paper_height: 11.00 print.print_paper_name: print.print_paper_size_type: 1 print.print_paper_size_unit: 0 print.print_paper_width: 8.50 print.print_plex_name: print.print_resolution: 0 print.print_resolution_name: print.print_reversed: false print.print_scaling: 1.00 print.print_shrink_to_fit: true print.print_to_file: false print.print_unwriteable_margin_bottom: 56 print.print_unwriteable_margin_left: 25 print.print_unwriteable_margin_right: 25 print.print_unwriteable_margin_top: 25 privacy.sanitize.migrateFx3Prefs: true storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1412881915 Important Locked Preferences ---------------------------- JavaScript ---------- Incremental GC: true Accessibility ------------- Activated: false Prevent Accessibility: 0 Library Versions ---------------- NSPR Expected minimum version: 4.10.7 Version in use: 4.10.7 NSS Expected minimum version: 3.17.1 Basic ECC Version in use: 3.17.1 Basic ECC NSSSMIME Expected minimum version: 3.17.1 Basic ECC Version in use: 3.17.1 Basic ECC NSSSSL Expected minimum version: 3.17.1 Basic ECC Version in use: 3.17.1 Basic ECC NSSUTIL Expected minimum version: 3.17.1 Version in use: 3.17.1 Experimental Features ---------------------
FredMcD
  • Top 10 Contributor
4261 solutions 59654 answers

Some problems occurs when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

Some problems occurs when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again; * Make sure your Internet security software is up-to-date (i.e. you are running the latest version). * Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see '''[https://support.mozilla.org/en-US/kb/configure-firewalls-so-firefox-can-access-internet Configure firewalls so that Firefox can access the Internet.]''' {web link}
yoshipop 1 solutions 4 answers

Chosen Solution

Thank you for the help. My firewall on the effected Mac was off before/after the updates. So playing around with the firewall settings didn't help.

I tried again fidget around with the add-ons. Disabling DoNotTrackMe (v.4.0.1249) fixed the problem. Enabling it again brings back the issue.

Thank you for the help. My firewall on the effected Mac was off before/after the updates. So playing around with the firewall settings didn't help. I tried again fidget around with the add-ons. Disabling DoNotTrackMe (v.4.0.1249) fixed the problem. Enabling it again brings back the issue.
FredMcD
  • Top 10 Contributor
4261 solutions 59654 answers

Helpful Reply

That was great work. Please contact DoNotTrackMe support and let them know.

Please flag your last post as Solved Problem so other will know.

That was great work. Please contact DoNotTrackMe support and let them know. Please flag your last post as '''Solved Problem''' so other will know.
yoshipop 1 solutions 4 answers

Thanks for the reminder though I can't flag my own post. ^_^

Thanks for the reminder though I can't flag my own post. ^_^