Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Recipients of my emails say that the sentences don't wrap. My emails go in HTML/Text mode.

  • 20 replies
  • 4 have this problem
  • 461 views
  • Last reply by Matt

more options

When I send the email, the sentences are an appropriate length and wrap.

All Replies (20)

more options

Windows XP makes it difficult to guess what the issue could be. So I will fall back to the most common cause, text pasted from word processing packages and spreadsheets. MAC mail is also a common cause. But your not using a MAC

more options

Thanks Matt. Unfortunately this problem occurs when I type directly into the email message. It seems to be linked to about two TB upgrades ago. Before that, I didn't have problems or at least I didn't hear about them. Any other ideas?

more options

Try setting the number of characters per line to wrap from about:config. You can access that from Options > Advanced > General > Config Editor. Search for "wrap" in about:config's search box. I have "editor.htmlWrapColumn" set to 72 and "mailnews.wraplength" also set to 72.

more options

Hi: I checked that and did change the mailnews.wraplength to 72. Then sent out a test email. The response was that sentences still aren't wrapping.

Here is everything that comes up in the Config Editor when I search for "wrap": mail.compose.wrap_to_windows_width User set Boolean True plain-text.wrap_long_lines " " " view_source.wrap_long_lines " " " mail.wrap_long_lines Default Boolean True mailnews.wraplength Default Integer 72

I don't see editor.htmlWrapColumn

Thanks for any help you can give. Patt

more options

Hmm, if you are using HTML then it's really the job of the recipient's email client to do the wrapping. None of the settings mentioned above should matter.

HTML is like word processing; text is organized by paragraphs, and is dynamically re-flowed to fit the margins as determined by paper size and font size. In our case, it's not paper size, but the width of the recipient's display window that should set the wrapping point.

Are you using an obscure font that recipients may not have?

Do you use a signature? Does it include any images? I've seen these "break" the line wrapping, as the client displaying it tries to accommodate the widest fixed-width line.

more options

A further thought is a table.

Text generated in a word processor and pasted into Thunderbird is almost always wrapped in a table. If the table is very wide, say you us a large monitor with a high resolution providing room for lots of character per line the recipients view may well be "forced" into mimicking yours because of the table.

The most common source of these tables in my experience outside of pasting from another program is in the signature. Especially corporate signatures placed on intranets for you to copy, or those generated by web sites and PHP scripts.

more options

Thanks for the responses. So far, no success. :>(

Zenos: I am using a signature with no images that I created by following the TB instructions to create a HTML signature. The font for the signature is Papyrus which is common to Windows programs. I have been using the same format for several years without a problem.

Matt: Most of the messages I send are generated in TB and not pasted from a Word document. I experimented with both and it didn't seem to make a difference.

I'm wondering if the problem lies in the new version of TB. Is that possible?

Thanks again for helping out.

more options

Just a thought: If the problem is due to the line length on my computer monitor, is there a way that I can set the line length automatically or would I need to manually break the line (hit "enter") as I type?

more options

The settings given previously are aimed at plain text, where you do set line length when composing. Typically it is set at 72 characters, in honour of ancient 80-column "glass teletype" displays. This harks back to the pre-GUI days when a computer said "C:\>".

Your display should not be affecting the line length on the recipient's computer, since their email client should flow the text to fit, and re-flow if the user changes the window size.

This problem is a puzzle. It surfaces every so often and I don't think we have a standard solution for it.

Now, I use Linux here and it most definitely doesn't have the Papyrus font installed, so I wouldn't see it.

Would you mind posting a sample message to me at

xenos at gmx dot co dot uk

so I can see if I get the non-wrapping here?

I recall some time ago users having layout trouble which seemed to be related to their use of a new font (Cambria Math?) and a bit of research showed that it was causing users trouble in other environments too. So a font might be part of this situation too.

Modified by Zenos

more options

It is late in the process for basic diagnostics, but restart your Thunderbird from the help menu with add-ons disabled and see if that makes a change.

There is a "nowrap" tag in HTML perhaps you have an add-on that uses it.

more options

Does your anti virus program insert a "scanned by" type message in outgoing mail? I have not personally seen that for years, but I understand many of them offer it as an option.

more options

Matt: I restarted TB and sent a message in my usual format with signature as well as one without an automatic signature. I'm waiting to see her response.

I have Avast and it does append a "scanned by" message on all the outgoing emails. I can't see where to alter that in the settings menu. Perhaps not an option with the free version?

Zenos: I sent a sample email. Hope it sheds some light on the problem at your end.

Thanks, guys. I appreciate you hanging in there to problem-solve.

more options

Matt: I just heard from my "tester". Both emails I sent her after restarting TB in Help mode still had non-wrapped lines. One of the emails was with a signature block and the other without. So those approaches didn't work.

Is there somewhere I can download the older version of TB? I didn't have this problem before the last two versions were downloaded.

more options

this avast thread covers removing their advertising from mail https://feedback.avast.com/responses/how-to-prevent-avast-from-modifying-my-e-mails-adding-advertisement

If you can not do that in the free version, send your tester an unscanned mail. You have not got a virus. Avast attests to that. There is nothing going to appear out of the vapors and insert itself into your email.

more options

Thanks, Matt. I've removed it. I think the "problem" has been changed to a "no problem at my end". Zenos checked out a sample email on his end and didn't find any problems with my email!

Thanks to both of you for giving your time and expertise! :)

more options

The OP has sent me a sample email. Having viewed it in Thunderbird, the Android mail client and on a Blackberry, it has appeared quite properly in all cases, with text wrapping to the display window width and re-wrapping when I change the window size. So it has been impossible to reproduce the effect reported by the OP's correspondents.

We still don't know if the non-wrapping issue is related to any specific mail client being used by the recipients.

more options

@Pattop. Are those complaining all using the same mail client? and version? These formatting errors are something I like to try and keep a handle on so anything further you can contribute would be useful

more options

Hi Matt: Here is the information from some of the folks who have problems with non-wrapping lines if there are longer paragraphs in my emails; there is no problem when the sentences are short or contain bulleted items.

1. Gmail (couldn't find version). Usually opened in Safari, Version 6.1.6 (7537.78.2) or Google Chrome, Version 37.0.2062.94.

2. Easystreet (couldn't find version). Opened in Firefox 32.

3. Hotmail (couldn't find version). Uses Linux system.

There could be others experiencing the same problem with my emails but they haven't brought it to my attention.

Thanks for any help you can give! Patt

more options

Another thought: My ISP provider is comcast.net. Could the provider's system create the problem? Patt

more options

I doubt it is your ISP. It is possible, but not all that probable.


At the risk of getting buried in mail, get some of them to send a message that does not wrap to me at Unicorn dot consulting at gmail dot com

Preferable the message should be saved to EML format before forwarding, so it is exactly as it is seen at the other end.

instructions for creating an EML file from a mail in Gmail are here http://email.about.com/od/gmailtips/qt/How-To-Save-An-Email-As-An-Eml-File-In-Gmail.htm

Are all of your problem recipients using Unix/Linux? (OSX is essentially a UNIX distribution, although Apple do not mention it much, IOS is also a direct descendant from NEXTsTEP) and as such it has a lot in common with Linux, but don't tell the Apple fans, they get upset for some reason when it is mentioned. It is convenient to forget that Apple bought NEXTsTEP to get Steve Jobs back and got the operating system in the deal

Modified by Matt