Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't access imap account on Thunderbird 31.0 in Ubuntu 14.04.1. Error: 'too many connections' with "imap server directory" setting

  • 4 replies
  • 16 have this problem
  • 579 views
  • Last reply by Wayne Mery

more options

I just installed Ubuntu 14.04.1 and am trying to set up Thunderbird (31.0).

I follow the usual setup (I have done this many times in the last few months on 12.04 and on another machine with 14.04) and use an existing email address, it finds the correct ports/connection security and then the status line says "Mail for <user-name@imap-server>: Sending login information...". If I click on Inbox it just hangs indefinitely.

(My other machines use Thunderbird to access my imap account with no issues.)

There is no firewall issue. Tcpdump on the server & client machines shows traffic on imap/imap2. In fact the traffic just keeps on going & going & going until I kill Thunderbird.

Modified by Wayne Mery

All Replies (4)

more options

Update:

I downloaded an older version from http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/24.7.0/linux-x86_64/en-US/ and bunzip2 & untarred the file, then ran ./thunderbird/thunderbird. This worked as expected (but is not integrated into the standard Ubuntu window manager setup).

In addition, I removed my .thunderbird directory and was able to create a new account without any issues.

If I start the 31.0 Thunderbird it just shows the busy icon with the status message "Looking for folders".

more options

When trying to connect using either Thunderbird 31.0 or 24.7 this morning I got the 'too many connections' every time, so was unable to check mail. After some slog, I discovered that the imap server had many messages of the form:

   Jul 28 10:35:10 crow xinetd[2126]: FAIL: imap per_source_limit from=::ffff:192.168.0.8

Restarting xinetd fixed the problem. However, since this is the first time I have ever encountered this limit with xinetd, I suspect it may be related to the problems at hand.

more options

Some resolution:

In my home directory I have some links to fairly deep directories. I use the "IMAP Server Directory" option to point to my actual mail. While I haven't confirmed this with tcpdump, when I remove the links, the 31.0 Thunderbird seems to work as expected. When I restore the links, it just hangs as before. So I am guessing that 31.0 Thunderbird doesn't restrict the directory search to the "IMAP Server Directory".

Not ideal, but I can live with the workaround.

more options

cooper.hat,

Can you try version 31.1.0 (due out in a couple days), with "imap server directory" setting? It will hopefully solve your issue, and we'd like to know from you if it helps or not.