Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

XP, Menu bar on, FF29.0.1 but orange button not gone. What to do?

  • 10 replies
  • 1 has this problem
  • 57 views
  • Last reply by Tony98

more options

The previous version of FF jumped to the version with the orange button without any decision on my part. I just turned the computer on one day and it had changed - which I was not pleased with. I've read the various replies and it seems that the orange button really shouldn't be there with v29 but it is.

How do I get rid of the orange button, or at least move it somewhere else? It is not show as an option on the 'Customise' screen (though it should be). I really prefer the exit symbol up in the top LH corner. How do I restore that exit symbol?

All Replies (10)

more options

Click Help, then click About Firefox, to determine what version of Firefox you actually have.

more options

Many of us are using Classic Theme Restorer (Customize Australis) {web link} Restore squared tabs, appmenu, add-ons bar, small button view and more on Australis UI (Windows/MacOSX/Linux + Fx 29+).

This will restore many of the things the last upgrade took away.

more options

You neglected to provide a listing of Installed Extensions when you created this thread. (by-passed installing the extension that auto-generates that info and "delivers" it to the forum software for us to view for support purposes)

Any chance that you installed the extension {Classic Theme Restorer (Customize Australis)} that FreMcD mentioned, and forgot that you installed it?

That orange Firefox button just ain't in the Firefox 29+ code base any more. Something in that Firefox Profile. like an extension, put that code back into Firefox 29.

Try using the Firefox SafeMode to verify what I said.

more options

Do you mean the Firefox icon on the title bar?

You can toggle the title bar via the Title Bar button in the Customize palette ("3-bar" Firefox menu button > Customize).

more options

Thanks for your replies.

Tony98 The version is 29.0.1, as stated in the heading

Fred McD I tried the 'Classic Theme Restorer' when the changes first occurred (because it was offered), but it didn't get rid of the orange button at top left. It was some weeks ago now and, frankly, Firefox had already played one dirty trick and I didn't want any more.

the ed-meister I tried the safe mode as per your instruction and the orange button was not there so I agree that something (presumably the 'Classic theme Restorer') has left it there (see reply to Fred above). My question remains - how do I get rid of the orange button? As a firm believer in 'If it ain't broke, don't fix it', I'd like to reverse the changes that Firefox installed without checking with me first.

cor-el The 'Customise' palette (a strange 'palette' designed in monochrome!) seems to offer items to add, but no opportunities to remove things. What is the point in going there? If the palette was in colour, and showed the orange button with a 'Remove' option then surely it would be be more useful?

more options

Are you referring to the Firefox icon on the title bar that open the window System menu with Move and Maximize?

As I wrote above, you can find a button the toggle the title bar on/off in the corner at the bottom left of the Customize palette window. Firefox 29 and later no longer have the orange Firefox menu button, but now come with a "3-bar" Firefox menu button at the right end of the Navigation Toolbar.

more options

Have you considered uninstalling (or removing) the 'Classic theme Restorer' extension?

If you do that the rectangular orange Firefox button will be gone!

As far as being a 'firm believer' goes - you broke it by installing that extension; as verified by the SafeMode troubleshooting exercise.

more options

To Cor-el it seems that there are many variations of screen and what you are describing doesn't seem to match with what I am seeing, but . . . .

To the edmiester . . . . having discovered the 'Classic Theme restorer' at the bottom of the Tools menu (aha!) I have managed to remove the orange button. Excellent!.

Your suggestion about "uninstalling (or removing) the 'Classic theme Restorer' extension" would be doubly useful if you explained how that can be done. I've not come across the concept of an 'extension' before in this context - presumably a programme modification? As it is not a programme in itself (unlike, say, programmes that modify Windows and which can be reversed in the Uninstall process) there is presumably a special procedure and I'm simply not aware of what that might be.

I didn't really break my 'firm belief' in the first place because as far as I was concerned, Firefox WAS broke and I used the only fix that seemed to be available.

more options

Firefox isn't "broke", it received a new UI with Firefox 29, which happens every 2, 3, or 4 years. Too many users didn't bother to "take the tour" when the new version first opened after installation or update, to learn how to use the new UI, and thus are now "lost".

There is a Search feature that the top of every forum page to help you find Support articles in this forum. https://support.mozilla.org/en-US/kb/disable-or-remove-add-ons#w_how-to-remove-extensions-and-themes

A basic feature that hasn't changed since Firefox 4 was released.

Hit Alt or F10 to show the Menu Bar and see the Tools menu. Or use { Ctrl + Shft + A } to open the Add-ons Manager directly.

Modified by the-edmeister

more options

I know you posted the version in the heading, but wanted you to check it was correct, as the behaviour you described didn't match the version.

Glad you got it fixed now.