Αναζήτηση υποστήριξης

Αποφύγετε τις απάτες υποστήριξης. Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου, ή να μοιραστείτε προσωπικές πληροφορίες. Παρακαλούμε αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής “Αναφορά κατάχρησης”.

Learn More

Why, every time do I get: "Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system. " after I think I've closed FF?

  • 11 απαντήσεις
  • 62 έχουν αυτό το πρόβλημα
  • 895 προβολές
  • Τελευταία απάντηση από citymorg

more options

I'm using Firefox 7.0.1 Every time I close Foxfire on my Win 7 (64 bit) computer and attempt to restart it, I get the "Firefox is already running" window. I then have to go to Task Manager and end the Firefox.exe process. When I restart Firefox it will do the same thing again when I think I've closed the application.

Επιλεγμένη λύση

Glad it worked. How about marking this post as solved ?

Ανάγνωση απάντησης σε πλαίσιο 👍 0

Όλες οι απαντήσεις (11)

more options
  • Try this.
  • Type in the address bar about:config.
  • Accept the warning.
  • In the page that appears, in the Filter box, type network.http.max-connections.
  • Change the value to 32 (which is probably set to 256 in your case).
  • Close the about:config page.
  • Restart the browser
more options

Hello amkeew, you were correct. It did show 256. I amended it to 32; however, it did not stop Foxfire from hanging up. I still have to go to Task Manager > Processes > and end Firefox.exe *32 for the application to really stop. My computer is a 64 bit system and I'm using Win 7.

Is there something else that I can try?

more options

You may need a clean install.

First export your bookmarks to a html file. (Bookmarks/Unsorted bookmarks will bring you History page where you can export your bookmarks). Note down your add-ons too.

Uninstall the old FF using free software like Revo Uninstaller. This will delete all the root directories and registries of old FF.

Now download the latest version of FF and install it. You can re-import your bookmarks from your saved html file.

You may still have to do what I suggested in my first post even after the clean install of FF.

more options

The clean install did the trick. Everything is working well now. Thank you.

more options

Επιλεγμένη λύση

Glad it worked. How about marking this post as solved ?

more options

I have had the same problem and i have done the 257 to 32 and i did the clean install but it still gives me the not responding problem when it comes back i get this blank messages with 2 buttons that r blank as well. Can you guys have this fixed by next update? If so can you guys have the update soon this is driving me insane.

more options

@maxmao

Closing Firefox properly will help reduce the problem, but not fix it, use File > Exit or "Firefox" button > Exit instead of the "X" in upper right corner of window, which merely closes the window. Even closing Firefox properly, you will still have to sometimes terminate through the "Processes" tab of the WTM ("Ctrl+Shift+Esc" in Windows 7 and 8). And Firefox 7.0.1 seems a lot worse at this.


Insanity: doing the same thing over and over again and expecting different results. -- Albert Einstein

more options

I have the same problem but cannot open firefox to alter anything,all I keep getting is

Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system.

I have deleted firefox & reinstalled it but the problem won't go away.

Any help would be appreciated. thanks

more options

@citymorg

If Firefox will still not start, remove the parent.lock file from the profile which is created each time Firefox is started to prevent other Firefox tasks from running, see

http://kb.mozillazine.org/Profile_in_use#Remove_the_profile_lock_file

more options

Did you remove the Firefox profile folder, but left the profiles.ini file?


Create a new profile as a test to check if your current profile is causing the problems.

See "Basic Troubleshooting: Make a new profile":

If that new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

See:

more options

Thanks for your replies it is greatly appreciated

I used dmcritchie reply & it worked

Thanks again to you both for the help.

Regards citymorg