Avatar for Username

Αναζήτηση στην υποστήριξη

Προσοχή στις απάτες! Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου ή να μοιραστείτε προσωπικά δεδομένα. Αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής «Αναφορά κατάχρησης».

Learn More

I need a older browser 3.5 for a FAFSA.ed.gov form online that is the required browser, can i get that?

  • 1 απάντηση
  • 2 έχουν αυτό το πρόβλημα
  • 10 προβολές
  • Τελευταία απάντηση από John99

more options

I need a older browser 3.5 for a FAFSA.ed.gov form online, that is the required browser, can i get that? I cant get past the sign in page due to not having the older browser, can I get the older browser?

I need a older browser 3.5 for a FAFSA.ed.gov form online, that is the required browser, can i get that? I cant get past the sign in page due to not having the older browser, can I get the older browser?

Όλες οι απαντήσεις (1)

more options

You could consider Firefox portable, to use solely for the FAFSA site. Firefox portable will I understand run Firefox 3.6.22, which is the latest and supported Firefox 3.6 version. See http://portableapps.com/apps/internet/firefox_portable

If you want just the one browser then Firefox 3.6 is available from : http://www.mozilla.org/en-US/firefox/all-older.html

(IIRC others have said Firefox 3.6 is compatible with FAFSA, firefox 3.6 is still supported, Firefox 3.5 is not. If you opted for Firefox 3.5 you would run increased security risks, so use of Firefox 3.5 is no longer recommended)