Αναζήτηση στην υποστήριξη

Προσοχή στις απάτες! Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου ή να μοιραστείτε προσωπικά δεδομένα. Αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής «Αναφορά κατάχρησης».

Learn More

Import Certificates button not functioning

  • 2 απαντήσεις
  • 0 έχουν αυτό το πρόβλημα
  • 23 προβολές
  • Τελευταία απάντηση από James Finnall

more options

I am attempting to import server certificates into Firefox. But the "Import" button does nothing when viewing certificates. Any work around? I need to import our server certificates into the Authorities section.

Ubuntu 22.04 Firefox installed through snap. Version 104.0 just upgraded this afternoon.

Thank you, James

I am attempting to import server certificates into Firefox. But the "Import" button does nothing when viewing certificates. Any work around? I need to import our server certificates into the Authorities section. Ubuntu 22.04 Firefox installed through snap. Version 104.0 just upgraded this afternoon. Thank you, James

Επιλεγμένη λύση

Hi James, do Browse... buttons call up your system file browser? If not, it's probably because Firefox is trying to call a file picker that isn't installed or isn't enabled.

I don't know which versions of Linux are affected, but some users need to make either of these two changes to make the file/directory picker appear. As a Windows user, I can't verify this myself

(A) Install xdg-desktop-portal

This would be from your package manager, I think.

(B) Turn off auto-detection of the GTK portal

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste widget.use-xdg-desktop-portal.file-picker and pause while the list is filtered

(3) Double-click the preference to display an editing field, and change the value to 0 then press Enter or click the blue check mark button to save the change. For reference, these are the valid values:

  • 0 => Never
  • 1 => Always
  • 2 => Auto-detect

Now... there are a bunch of other preferences starting with widget.use-xdg-desktop-portal. and I have no idea what those do. If your distribution has a support site with a Firefox board or active Firefox discussions, you might search there for more tips.

Ανάγνωση απάντησης σε πλαίσιο 👍 0

Όλες οι απαντήσεις (2)

more options

Επιλεγμένη λύση

Hi James, do Browse... buttons call up your system file browser? If not, it's probably because Firefox is trying to call a file picker that isn't installed or isn't enabled.

I don't know which versions of Linux are affected, but some users need to make either of these two changes to make the file/directory picker appear. As a Windows user, I can't verify this myself

(A) Install xdg-desktop-portal

This would be from your package manager, I think.

(B) Turn off auto-detection of the GTK portal

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste widget.use-xdg-desktop-portal.file-picker and pause while the list is filtered

(3) Double-click the preference to display an editing field, and change the value to 0 then press Enter or click the blue check mark button to save the change. For reference, these are the valid values:

  • 0 => Never
  • 1 => Always
  • 2 => Auto-detect

Now... there are a bunch of other preferences starting with widget.use-xdg-desktop-portal. and I have no idea what those do. If your distribution has a support site with a Firefox board or active Firefox discussions, you might search there for more tips.

Χρήσιμο;

more options

Package was installed and up to date. The last item corrected the issue. Changing the setting from 2 to 0 allowed the file picker to appear. Thank you for the response. James

Χρήσιμο;

Υποβολή ερώτησης

Πρέπει να συνδεθείτε στον λογαριασμό σας για να απαντήσετε σε δημοσιεύσεις. Ξεκινήστε μια νέα ερώτηση εάν δεν διαθέτετε ακόμα λογαριασμό.