Αναζήτηση στην υποστήριξη

Προσοχή στις απάτες! Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου ή να μοιραστείτε προσωπικά δεδομένα. Αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής «Αναφορά κατάχρησης».

Learn More

Firefox cannot open file manager

  • 3 απαντήσεις
  • 1 έχει αυτό το πρόβλημα
  • 26 προβολές
  • Τελευταία απάντηση από jonzn4SUSE

more options

I am on Arch Linux using i3. I have been using Firefox for a while but recently switched from Nautilus to pcmanfm as my file manager. Now Firefox is unable to save any file or do anything else that requires opening the file manager. Running it through the terminal I get:

"Can't open portal file chooser: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.portal.Desktop was not provided by any .service files"

I have xdg-desktop-portal installed and have tried xdg-desktop-portal-{gnome, gtk, and kde}. I have also tried setting widget.use-xdg-desktop-portal to both true and false, neither of which changed anything. Reinstalling Nautilus also doesn't fix it. Does anybody know what could be causing this?

I am on Arch Linux using i3. I have been using Firefox for a while but recently switched from Nautilus to pcmanfm as my file manager. Now Firefox is unable to save any file or do anything else that requires opening the file manager. Running it through the terminal I get: "Can't open portal file chooser: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.portal.Desktop was not provided by any .service files" I have xdg-desktop-portal installed and have tried xdg-desktop-portal-{gnome, gtk, and kde}. I have also tried setting widget.use-xdg-desktop-portal to both true and false, neither of which changed anything. Reinstalling Nautilus also doesn't fix it. Does anybody know what could be causing this?

Όλες οι απαντήσεις (3)

more options

I had a problem years ago after switching file managers. In my case (different distro) there was a file mimeinfo.cache in /usr/share/applications/. I had to rearrange the order of applications by putting the file manager I wanted to use first in the line commencing "inode/directory=".

I see several old questions which remain unanswered.

more options

Unfortunately, I had already checked that file, as well as the mimeapps.cache in other locations. They are all already set to pcmanfm.desktop.

more options

Try downloading another copy of Firefox, run it from the folder and see if you have the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release