Avatar for Username

Αναζήτηση στην υποστήριξη

Προσοχή στις απάτες! Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου ή να μοιραστείτε προσωπικά δεδομένα. Αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής «Αναφορά κατάχρησης».

Learn More

How to make Firefox ask before closing?

  • 3 απαντήσεις
  • 1 έχει αυτό το πρόβλημα
  • 1 προβολή
  • Τελευταία απάντηση από cor-el

more options

in about:config page the options: browser.tabs.warnOnClose (true - default) browser.tabs.warnOnCloseOtherTabs (true - default) browser.sessionstore.warnOnQuit (false - default) browser.warnOnQuit true (true - default)

But when i do Ctrl+q accidentally, it closes the only Firefox window i have. This window has many tabs open. Yes it restore next time, but i want FF to ask me before closing it.

FF 84.0.1 Arch Linux

in about:config page the options: browser.tabs.warnOnClose (true - default) browser.tabs.warnOnCloseOtherTabs (true - default) browser.sessionstore.warnOnQuit (false - default) browser.warnOnQuit true (true - default) But when i do Ctrl+q accidentally, it closes the only Firefox window i have. This window has many tabs open. Yes it restore next time, but i want FF to ask me before closing it. FF 84.0.1 Arch Linux

Τροποποιήθηκε στις από το χρήστη #367259

Επιλεγμένη λύση

It appears that all 4 config. options mentioned in OP has to be set to true. In my case the one that was false was: browser.sessionstore.warnOnQuit Developers should fix this and let this option be true by default.

Ανάγνωση απάντησης σε πλαίσιο 👍 0

Όλες οι απαντήσεις (3)

more options

Επιλεγμένη λύση

It appears that all 4 config. options mentioned in OP has to be set to true. In my case the one that was false was: browser.sessionstore.warnOnQuit Developers should fix this and let this option be true by default.

more options

There is a checkbox in "Options/Preferences -> General -> Startup" for the browser.sessionstore.warnOnQuit pref.

  • Warn you when quitting the browser
more options

Firefox 87+ versions have a pref to disable Ctrl+Q to close Firefox.

  • browser.quitShortcut.disabled = true

You need to close and restart Firefox after toggling this pref.