Αναζήτηση υποστήριξης

Αποφύγετε τις απάτες υποστήριξης. Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου, ή να μοιραστείτε προσωπικές πληροφορίες. Παρακαλούμε αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής “Αναφορά κατάχρησης”.

Learn More

Pinned tabs show part of the title and got wider (version 72.0.1)

  • 7 απαντήσεις
  • 1 έχει αυτό το πρόβλημα
  • 153 προβολές
  • Τελευταία απάντηση από Sander van Harmelen

more options

It looks like (at least on macOS 10.15.2) the latest update (72.0.1) introduced either a bug or a change in how pinned tabs are rendered as since today I noticed that my pinned tabs are a lot wider and are showing part of the title (see attached image, the first two tabs are pinned tabs).

Is this something I can change or customize, or is this a bug?

Συνημμένα στιγμιότυπα

Επιλεγμένη λύση

You aren't using code in userChrome.css that could cause this because pinned tabs set the text label width to 0px, so you should never see text ?

.tab-label-container[pinned] {
    width: 0;
}
Ανάγνωση απάντησης σε πλαίσιο 👍 1

Όλες οι απαντήσεις (7)

more options

Επιλεγμένη λύση

You aren't using code in userChrome.css that could cause this because pinned tabs set the text label width to 0px, so you should never see text ?

.tab-label-container[pinned] {
    width: 0;
}
more options

Thanks for the pointer! My userChrome.css looked like this and it turns out the last part caused the isssue...

``` @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

/* Use the full titlebar for tabs */ .titlebar-spacer[type="pre-tabs"] {

 width: 13px !important;
 max-width: 13px !important;

} .titlebar-spacer[type="post-tabs"] {

 width: 0px !important;
 max-width: 0px !important;

}

/* Always show the close button when hovering over a tab */ .tabbrowser-tab:not([pinned="true"]):hover .tab-close-button:not([selected="true"]) {

 display: -moz-box !important;

}

/* Do not show the blue tab line */ .tabbrowser-tab .tab-line {

 display: none !important;

}

/* Prevent tab overflow */ .tabbrowser-tab {

 min-width: initial !important;

} .tab-content {

 overflow: hidden !important; ===> this cause the issue

} ```

After removing the last 3 lines it all works again, but if I open a lot of tabs I do get the overflow again. Do you know another way to prevent that?

Thanks for your help!!

more options

Well it actually fine without those 3 lines. It does overflow, but only when I have way more tabs open then I should. So I'm good with just removing the three lines and leaving it like that.

Thanks again!

more options

In what way does it overflow?

Can you attach a screenshot ?

more options

Thanks for the follow up, but its really not needed. I happy with my config again and it only overflows when there are way too many tabs open. So I'm good!

For reference I'm talking about this behavior (tab scrolling/overflow, not sure what to call it): https://www.reddit.com/r/firefox/comments/b3slhs/why_is_there_absolutely_no_possible_way_to/

I used the solution described in there which worked... Until now that is :)

more options

What I do see now is that when I hover over a tab it resizes to show the tab-close-button. It didn't use to do that and if I put the 3 lines back it doesn't anymore.

So fixed one, but introduced another ;)

more options

Adding the 3 lines back with a small adjustment made it work as expected again:

.tab-content:not([pinned="true"]) {

 overflow: hidden !important;

}

Thanks again for your help!