X
Πατήστε εδώ για μετάβαση στην έκδοση της ιστοσελίδας για κινητές συσκευές.

Φόρουμ υποστήριξης

LAN Bookmark fails in Firefox only

Δημοσιεύτηκε

iMac OS 10.16.6 Firefox Quantum 69.0.1 (64-bit) Safari 13.0.1 Netgear D6220 Firmware V1.0.0.52_1.0.52

I usually access the admin web page for my D6220 Netgear modem/router from Firefox via the address https://www.routerlogin.net/start.htm This has just now stopped working - Firefox reporting "Unable to connect".

The modem is functioning - I can access the internet and email without difficulty.

Bizarrely, if I use the LAN IP address for the modem/router (10.175.0.1), Firefox connects to the admin web page straight away.

Even more strangely, if I use Safari, I can connect to the admin web page for my D6220 Netgear modem/router using both https://www.routerlogin.net/start.htm and the LAN IP address (10.175.0.1)

So, it seems to be a Firefox issue - I have restarted Firfox in Safe mode with add-ons disabled, restarted my iMac, deleted the Firefox cache, restarted the modem. No change.

This is a very recent issue, happening in the last 2-3 weeks.

Suggestions please :-)

iMac OS 10.16.6 Firefox Quantum 69.0.1 (64-bit) Safari 13.0.1 Netgear D6220 Firmware V1.0.0.52_1.0.52 I usually access the admin web page for my D6220 Netgear modem/router from Firefox via the address https://www.routerlogin.net/start.htm This has just now stopped working - Firefox reporting "Unable to connect". The modem is functioning - I can access the internet and email without difficulty. Bizarrely, if I use the LAN IP address for the modem/router (10.175.0.1), Firefox connects to the admin web page straight away. Even more strangely, if I use Safari, I can connect to the admin web page for my D6220 Netgear modem/router using both https://www.routerlogin.net/start.htm and the LAN IP address (10.175.0.1) So, it seems to be a Firefox issue - I have restarted Firfox in Safe mode with add-ons disabled, restarted my iMac, deleted the Firefox cache, restarted the modem. No change. This is a very recent issue, happening in the last 2-3 weeks. Suggestions please :-)
Παράθεση

Επιπρόσθετες λεπτομέρειες συστήματος

Εγκατεστημένα αρθρώματα

Adblock Plus Clear Flash Cookies DuckDuckGo Privacy Essentials Facebook Containers Ghostery HTPPS Everywhere Unpaywall

But problem still remains if starting in safe mode.

Εφαρμογή

  • Πλατφόρμα χρήστη: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:69.0) Gecko/20100101 Firefox/69.0

Περισσότερες πληροφορίες

jscher2000
  • Top 10 Contributor
8765 λύσεις 71703 απαντήσεις
Δημοσιεύτηκε

When I hit that address, I get a page informing me that I'm not connected to my router's wi-fi network. I'm assuming you probably are connected to your Netgear's wi-fi network or you would get that page, too, instead of a failure to connect.

There's an internal page you can use for testing network-related things. Type or paste the following in the address bar and press Enter/Return to submit it:

about:networking#dnslookuptool

If DNS Lookup isn't selected in the left column, click it.

Then try www.routerlogin.net there to see whether Firefox is able to retrieve the expected local IP address. Any luck?


Note: if DNS isn't working AND you are using DNS over HTTPS, you may need to create an exception for this hostname. To do that:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste TRR and pause while the list is filtered

(3) Double-click the network.trr.excluded-domains preference to display a dialog where you can enter or edit host names:

  • if this field is not blank: type or paste a comma, and then (with no space) type or paste www.routerlogin.net and click OK

That should prevent Firefox from using the DoH resolver to look up your local router address.

When I hit that address, I get a page informing me that I'm not connected to my router's wi-fi network. I'm assuming you probably are connected to your Netgear's wi-fi network or you would get that page, too, instead of a failure to connect. There's an internal page you can use for testing network-related things. Type or paste the following in the address bar and press Enter/Return to submit it: about:networking#dnslookuptool If DNS Lookup isn't selected in the left column, click it. Then try www.routerlogin.net there to see whether Firefox is able to retrieve the expected local IP address. Any luck? ---- Note: if DNS isn't working AND you are using DNS over HTTPS, you may need to create an exception for this hostname. To do that: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''TRR''' and pause while the list is filtered (3) Double-click the '''network.trr.excluded-domains''' preference to display a dialog where you can enter or edit host names: * if this field is blank: type or paste www.routerlogin.net and click OK * if this field is not blank: type or paste a comma, and then (with no space) type or paste www.routerlogin.net and click OK That should prevent Firefox from using the DoH resolver to look up your local router address.

Τροποποιήθηκε στις από το χρήστη jscher2000

Σάς φάνηκε χρήσιμο; 0
Παράθεση
cor-el
  • Top 10 Contributor
  • Moderator
17532 λύσεις 158526 απαντήσεις
Δημοσιεύτηκε

It sounds that there is a problem with doing a DNS lookup for local website.

Did you recently changed the DNS server (VPN or Proxy or DoH) that could be causing this?

It sounds that there is a problem with doing a DNS lookup for local website. Did you recently changed the DNS server (VPN or Proxy or DoH) that could be causing this?
Σάς φάνηκε χρήσιμο; 0
Παράθεση
Δημοσιεύτηκε

Ιδιοκτήτης ερώτησης

The iMac is connected to the router/modem over ethernet or, more specifically, ethernet over powerline - never caused any issues before.

Thanks for about:networking, never knew that existed. I keep discovering things in Firefox I didn't know about.

If I enter www.routerlogin.net it returns 10.175.0.1

Entering www.routerlogin.net into the address bar still gives me the Unable to Connect Page, entering 10.175.0.1 connects with no problem .....

Safari still connects with either form of the address, so I don't see that it's anything to do with the DNS lookup?

I've made no changes of which I'm aware to the network setup.

Network.trr.excluded-domains shows localhost,local which doesn't sound right .... Adding www.routerlogin.net seems to have no affect, although perhaps I need to restart Firefox?

The iMac is connected to the router/modem over ethernet or, more specifically, ethernet over powerline - never caused any issues before. Thanks for '''about:networking''', never knew that existed. I keep discovering things in Firefox I didn't know about. If I enter www.routerlogin.net it returns 10.175.0.1 Entering www.routerlogin.net into the address bar still gives me the Unable to Connect Page, entering 10.175.0.1 connects with no problem ..... Safari still connects with either form of the address, so I don't see that it's anything to do with the DNS lookup? I've made no changes of which I'm aware to the network setup. '''Network.trr.excluded-domains''' shows '''localhost,local''' which doesn't sound right .... Adding www.routerlogin.net seems to have no affect, although perhaps I need to restart Firefox?
Σάς φάνηκε χρήσιμο;
Παράθεση
jscher2000
  • Top 10 Contributor
8765 λύσεις 71703 απαντήσεις
Δημοσιεύτηκε

UKLarry said

Thanks for about:networking, never knew that existed. I keep discovering things in Firefox I didn't know about.
If I enter www.routerlogin.net it returns 10.175.0.1
Entering www.routerlogin.net into the address bar still gives me the Unable to Connect Page, entering 10.175.0.1 connects with no problem

I can't explain that. If Firefox knows the IP address corresponding to the host name, why doesn't it connect using the host name??

''UKLarry [[#answer-1256906|said]]'' <blockquote> Thanks for '''about:networking''', never knew that existed. I keep discovering things in Firefox I didn't know about. <Br> If I enter www.routerlogin.net it returns 10.175.0.1 <br> Entering www.routerlogin.net into the address bar still gives me the Unable to Connect Page, entering 10.175.0.1 connects with no problem </blockquote> I can't explain that. If Firefox knows the IP address corresponding to the host name, why doesn't it connect using the host name??
Σάς φάνηκε χρήσιμο;
Παράθεση
Δημοσιεύτηκε

Ιδιοκτήτης ερώτησης

jscher2000 said

UKLarry said
Thanks for about:networking, never knew that existed. I keep discovering things in Firefox I didn't know about.
If I enter www.routerlogin.net it returns 10.175.0.1
Entering www.routerlogin.net into the address bar still gives me the Unable to Connect Page, entering 10.175.0.1 connects with no problem

I can't explain that. If Firefox knows the IP address corresponding to the host name, why doesn't it connect using the host name??

Beats me as well!

Got to be something to do with Firefox as it's not an issue with Safari.

I'm just wondering if there's something in the modem/router doing the blocking, although it's odd it's only applying it to Firefox and not Safari. Rebooting the router didn't help so I'm thinking on trying a factory reset of the router.

''jscher2000 [[#answer-1257437|said]]'' <blockquote> ''UKLarry [[#answer-1256906|said]]'' <blockquote> Thanks for '''about:networking''', never knew that existed. I keep discovering things in Firefox I didn't know about. <Br> If I enter www.routerlogin.net it returns 10.175.0.1 <br> Entering www.routerlogin.net into the address bar still gives me the Unable to Connect Page, entering 10.175.0.1 connects with no problem </blockquote> I can't explain that. If Firefox knows the IP address corresponding to the host name, why doesn't it connect using the host name?? </blockquote> Beats me as well! Got to be something to do with Firefox as it's not an issue with Safari. I'm just wondering if there's something in the modem/router doing the blocking, although it's odd it's only applying it to Firefox and not Safari. Rebooting the router didn't help so I'm thinking on trying a factory reset of the router.
Σάς φάνηκε χρήσιμο;
Παράθεση
Δημοσιεύτηκε

Ιδιοκτήτης ερώτησης

Did a factory reset of the modem/router - problem remains :-(

Did a factory reset of the modem/router - problem remains :-(
Σάς φάνηκε χρήσιμο;
Παράθεση
Κάντε μια ερώτηση

Πρέπει να συνδεθείτε στο λογαριασμό σας για να απαντήσετε στις δημοσιεύσεις. Παρακαλούμε ξεκινήστε μια νέα ερώτηση, αν δεν έχετε ήδη λογαριασμό.