Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why the website is displayed like this only in Firefox

  • 8 ŋuɖoɖowo
  • 1 masɔmasɔ sia le esi
  • 1 view
  • Nuɖoɖo mlɔetɔ FredMcD

more options

Hey folks, Do any one if have an idea of Why this website top is being displayed like this in Firefox only?

- http://mindfulenglish.com.br/

The problem is, the top background is supposed to be "transparent", with only the image as the background. In Firefox, there is this white bar ...

I just tested in Chrome and Safari and it is ok there.

I'm using Firefox Quantum 57.0.3 (64-bit).

This is the code I added to my Wordpress theme to show the background image like that

/* Move the page content up to cover the header */ /* Sized for default small device breakpoint of 768 px - change this value if you have a custom breakpoint */ @media (min-width: 768px) {

 .fl-page-content {
    margin-top: -160px; /*Adjust depending on the height of the header for medium devices*/

} /* Stack the header on top of the content and make the background transparent */

 .fl-page-header-primary {
    position: relative;
    z-index: 3;
    background: none;
 }

} /* For large screens, change the margin-top value to accommodate the narrower heading */ @media (min-width: 992px) {

 .fl-page-content {
   margin-top: -180px; /*Adjust depending on the height of the header for large devices*/
 }

}


Much appreciated, thank you all.

Hey folks, Do any one if have an idea of Why this website top is being displayed like this in Firefox only? - http://mindfulenglish.com.br/ The problem is, the top background is supposed to be "transparent", with only the image as the background. In Firefox, there is this white bar ... I just tested in Chrome and Safari and it is ok there. I'm using Firefox Quantum 57.0.3 (64-bit). This is the code I added to my Wordpress theme to show the background image like that /* Move the page content up to cover the header */ /* Sized for default small device breakpoint of 768 px - change this value if you have a custom breakpoint */ @media (min-width: 768px) { .fl-page-content { margin-top: -160px; /*Adjust depending on the height of the header for medium devices*/ } /* Stack the header on top of the content and make the background transparent */ .fl-page-header-primary { position: relative; z-index: 3; background: none; } } /* For large screens, change the margin-top value to accommodate the narrower heading */ @media (min-width: 992px) { .fl-page-content { margin-top: -180px; /*Adjust depending on the height of the header for large devices*/ } } Much appreciated, thank you all.

Ŋuɖoɖo si wotia

Hi gabrielmulle, you need to match that tag's specific selector:

class="fl-page-nav-col col-sm-12"

This should do it:

.fl-page-nav-col.col-sm-12 {
  float: none !important;
}
Xle ŋuɖoɖo sia le goya me 👍 1

All Replies (8)

more options

I look at the website, but could not see any problem.

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!


Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Type about:preferences<enter> in the address bar.

  • Cookies; Select Privacy. Under History, select

Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.

  • Cache; Select Advanced > Network.

[v57+] Select Privacy. Across from Cached Web Content, Press Clear Now.

If there is still a problem, https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode A small dialog should appear. Click Start In Safe Mode (not Refresh). While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Then restart.

more options

This floated element

<div class="fl-content col-md-12">

starts further down in Firefox than in Chrome.

If you override the float for the following element in the navigation bar

<div class="fl-page-nav-col col-sm-12">

using for example:

<div class="fl-page-nav-col col-sm-12" style="float:none!important">

Then the problem goes away.

I don't know what's going on that explains the difference between Firefox (57 and 52 ESR) and Chrome (63).

more options

Hey thank you guys.

Sorry FredMcD, I assumed everyone using Firefox would be able to see the problem. Here you go.

jscher2000, so, I did it as you mentioned in the Console and it worked like a charm, but I'm not sure how I would do that as I believe I would need to edit Wordpress code.

I tried in the CSS code that I can edit, but it didn't work. See below what I put. Any idea to make it work in this CSS code?

@media (min-width: 768px) {

 .fl-page-content {
    margin-top: -160px;
    float: none;

}

/* Stack the header on top of the content and make the background transparent */

 .fl-page-header-primary {
    position: relative;
    z-index: 3;
    background: none;
 }

}

@media (min-width: 992px) {

 .fl-page-content {
   margin-top: -180px;
   float: none;
 }

}

Thanks guys. Have a great new year.

more options

W3C.org (World Wide Web Consortium) in charge of standards and practices and future development of web pages and web browsers make the rules on code. Mozilla Firefox follows these rules. W3C.org Who make the rules for web code. HTML https://validator.w3.org/ CSS https://jigsaw.w3.org/css-validator/ and https://validator.w3.org/i18n-checker/ and http://mobile.css-validator.org/

Firefox and Google for page ranking just love clean code , please fix errors https://validator.w3.org/nu/?doc=http%3A%2F%2Fmindfulenglish.com.br%2F for HTML ERRORS

CSS ERRORS : https://jigsaw.w3.org/css-validator/validator?uri=http%3A%2F%2Fmindfulenglish.com.br%2F&profile=css3&usermedium=all&warning=1&vextwarning=&lang=en

Please let us know if this solved your issue or if need further assistance.

more options

Ɖɔɖɔɖo si wotia

Hi gabrielmulle, you need to match that tag's specific selector:

class="fl-page-nav-col col-sm-12"

This should do it:

.fl-page-nav-col.col-sm-12 {
  float: none !important;
}
more options

You are the man, jscher2000. Case resolved. It is strange, right? well, doesn't matter now. Thank you!

more options

When you're using complex themes/frameworks, it's often difficult to figure out "why" but still possible to fix it. :-)

more options

gabrielmulle said

Sorry FredMcD, I assumed everyone using Firefox would be able to see the problem.

Sometimes the problem is not the website, but something about the browser.

Glad this was worked out.