X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Keyboard language changed only in Firefox not other programmes

Veröffentlicht

I have Firefox in English but I use a Spanish keyboard, meaning some keys like question marks or quotation marks are in different places, there are accents, a key for ç, etc. It has always worked normally but today, while the keyboard is working correctly with all other programmes in Firefox it works as if the settings were changed to an English (I think) keyboard.

I don't have that problem with Chrome though, it's just Firefox. How is that possible (add question mark here, I can't guess what key I'im supposed to use for it).

I haven't changed anything in the settings, so the only possibility could be some kind of shortcut I've accidentally pressed, even though I don't know how that's even possible, as I assumed you can't have several keyboard language settings selected at the same time depending on the programme you're using.

I type in different languages so this is terribly annoying! Thanks for any help.

I have Firefox in English but I use a Spanish keyboard, meaning some keys like question marks or quotation marks are in different places, there are accents, a key for ç, etc. It has always worked normally but today, while the keyboard is working correctly with all other programmes in Firefox it works as if the settings were changed to an English (I think) keyboard. I don't have that problem with Chrome though, it's just Firefox. How is that possible (add question mark here, I can't guess what key I'im supposed to use for it). I haven't changed anything in the settings, so the only possibility could be some kind of shortcut I've accidentally pressed, even though I don't know how that's even possible, as I assumed you can't have several keyboard language settings selected at the same time depending on the programme you're using. I type in different languages so this is terribly annoying! Thanks for any help.

Ausgewählte Lösung

It is possible that you have switched the keyboard layout by accident by using the key sequence to rotate the layout.

Windows remembers the keyboard layout setting per application and you may have changed the keyboard layout by accident via a keyboard shortcut.

Make sure that you have the Language bar visible on the Windows Taskbar

  • You can do that via the right-click context menu of the Taskbar: Toolbars > Language Bar
  • Check the keyboard language (keyboard layout) setting for the application that has focus via the icon on the Language bar
  • You need to do that while Firefox has focus because Windows remembers the keyboard layout setting per application
  • The default key combination to rotate the layout is the Ctrl+Shift or Alt+Shift combination that is used in Firefox for menu items, so it is quite possible to change the layout accidentally.
  • To avoid an unintentional switch, assign a specific key sequence (Alt/Ctrl+Shift+number) to select keyboard layouts and remove the key combination to rotate layouts (Alt+Shift or Ctrl+Shift)
  • Control Panel > Regional and Language Options > Keyboards and Languages > Change keyboards > Advanced key settings > Change key sequence
Diese Antwort im Kontext lesen 2

Mehr Details zum System

Installierte Plugins

  • Version 5.2.4.18058
  • Shockwave Flash 12.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.06
  • Next Generation Java Plug-in 10.51.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.7.148
  • VLC media player Web Plugin 2.1.0
  • WildTangent Games App V2 Presence Detector
  • 5.1.20913.0
  • Unity Player 4.1.2f1
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0

Weitere Informationen

cor-el
  • Top 10 Contributor
  • Moderator
16712 Lösungen 151144 Antworten
Veröffentlicht

Ausgewählte Lösung

It is possible that you have switched the keyboard layout by accident by using the key sequence to rotate the layout.

Windows remembers the keyboard layout setting per application and you may have changed the keyboard layout by accident via a keyboard shortcut.

Make sure that you have the Language bar visible on the Windows Taskbar

  • You can do that via the right-click context menu of the Taskbar: Toolbars > Language Bar
  • Check the keyboard language (keyboard layout) setting for the application that has focus via the icon on the Language bar
  • You need to do that while Firefox has focus because Windows remembers the keyboard layout setting per application
  • The default key combination to rotate the layout is the Ctrl+Shift or Alt+Shift combination that is used in Firefox for menu items, so it is quite possible to change the layout accidentally.
  • To avoid an unintentional switch, assign a specific key sequence (Alt/Ctrl+Shift+number) to select keyboard layouts and remove the key combination to rotate layouts (Alt+Shift or Ctrl+Shift)
  • Control Panel > Regional and Language Options > Keyboards and Languages > Change keyboards > Advanced key settings > Change key sequence
It is possible that you have switched the keyboard layout by accident by using the key sequence to rotate the layout. * http://support.microsoft.com/kb/258824 - How to change your keyboard layout Windows remembers the keyboard layout setting per application and you may have changed the keyboard layout by accident via a keyboard shortcut. * http://support.microsoft.com/kb/306993 - HOW TO: Use the Language Bar in Windows XP * http://windows.microsoft.com/en-US/windows7/The-Language-bar-overview The Language bar (overview) Make sure that you have the Language bar visible on the Windows Taskbar * You can do that via the right-click context menu of the Taskbar: Toolbars > Language Bar * Check the keyboard language (keyboard layout) setting for the application that has focus via the icon on the Language bar * You need to do that while Firefox has focus because Windows remembers the keyboard layout setting per application * The default key combination to rotate the layout is the Ctrl+Shift or Alt+Shift combination that is used in Firefox for menu items, so it is quite possible to change the layout accidentally. * To avoid an unintentional switch, assign a specific key sequence (Alt/Ctrl+Shift+number) to select keyboard layouts and remove the key combination to rotate layouts (Alt+Shift or Ctrl+Shift) * Control Panel > Regional and Language Options > Keyboards and Languages > Change keyboards > Advanced key settings > Change key sequence

Fragesteller

Thanks so much for a quick and accurate reply!

I didn't know Windows remembered the keyboard language per application, which is what I found so puzzling. Solved!

Thanks so much for a quick and accurate reply! I didn't know Windows remembered the keyboard language per application, which is what I found so puzzling. Solved!
cor-el
  • Top 10 Contributor
  • Moderator
16712 Lösungen 151144 Antworten
Veröffentlicht

You're welcome.

You're welcome.