Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Search preferences

  • 4 Antworten
  • 1 hat dieses Problem
  • Letzte Antwort von cor-el

more options

how do I keep my search preferences from changing every time I open Firefox? I prefer to use google as my main search engine and I have set it to this in my preferences thru the option menu. However every time I quit and then reopen Firefox my search engine reverts to yahoo? Why Yahoo? and why does this happen and how do I stop it?

Alle Antworten (4)

more options

Usually this kind of hijack is caused by an add-on or by external malware. Let's start with the add-on angle:

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

If there is at least one extension before the next heading -- "Recommended Extensions" -- please continue:

Then cast a critical eye over the list below that heading. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that mentions search or privacy? Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove). For your privacy and security, don't let mystery programs linger here.

Any improvement?

If that section of the Add-ons page is blank or inaccessible:

Try accessing the page in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions so they can't interfere with your use of Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart. A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

If Firefox is not running: Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead of the option/alt key.) A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Can you regain control of your default search setting?

Hilfreich?

more options

No, this did not help. This problem seems to occur every year and usually I can fix it when I start up in safe mode and and then start up in 'regular' mode and the problem goes away for months at a time. That did not solve the problem this time. I don't really have add-ons aside from auto fill and so getting rid of add-ons isn't much of an issue. What is so annoying is that I can change my search preferences to my preferred and they will stay that way for days and then one day it switches from google to yahoo search again.

Hilfreich?

more options

Is Yahoo listed in Preferences ('Search' page) under Search Shortcuts? If so, you can select and remove it there. I don't have Yahoo (although I have Bing, which I don't want) so you may have added it yourself.

Hilfreich?

more options

Did this still happen when you start Firefox in Safe Mode ?

You can check for recently installed suspicious or unknown extensions.


You can rename/remove search.json.mozlz4 in the Firefox profile folder with Firefox closed to rebuild the search engines registry.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Firefox will rebuild search.json.mozlz4 from the builtin search engines.

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.