Hilfe durchsuchen

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Stop saving all image files as WebP?

  • 24 Antworten
  • 5 haben dieses Problem
  • 6892 Aufrufe
  • Letzte Antwort von Chris Ilias

more options

I understand the newest version of Firefox offers support for WebP images, which is cool and great... but not when I need to download those images for use on my computer. As an artist I need to be able to save things as .jpg or .png for my art programs (or even preview) to be able to open them. Is there any way to make this an option, or to not default to webp when saving images?

I've also tried changing the extension on the file using the "all files" option but it just corrupts the file and won't open them.

Angefügte Screenshots

Ausgewählte Lösung

Alle Antworten (4)

more options

Hi rachaelspreston, it's your choice, obviously. When a browser indicates to a server that it can accept webP images, the server can compress the JPEG on the fly using a webP container -- without changing the file name. Each browser currently handles this differently:

  • Internet Explorer 11: can't decompress webP, sites do not substitute webP for JPEG
  • Chrome: accepts webP, and when you save, it can convert to different formats on the fly based on the file extension
  • Firefox: accepts webP, and when you save, it saves in webP format regardless of the file extension

It would be ideal if Firefox were to get Chrome's ability to convert to different formats, but we don't have that yet, so you can use other workarounds or use a different browser.

I think my latest extension is the easiest way to reduce sites substituting webP for JPEG or PNG: https://addons.mozilla.org/firefox/addon/dont-accept-webp/

more options

Ok I have this problem and a solution! I'm using Win7 Pro. This really should be fixed Mozilla? For the right click and Save Image As feature Firefox should have a option to save as normal jpeg please fix.

My solution is Right Click Image - Select "View Image Info"-(it should start on the Media Tab)

Select the Image Address in the list box, the image should preview!

Now Select "Save As" and the image saved will be correct viewable jpg

Its a pain but it works!

You can also Copy image URL and paste into another browser and save! What a pain! You can also open the WebP images in "Paint" then crop then and save as jpeg! What a pain!

Geändert am von Rods

more options

I click on a PNG IMAGE show image, right click on the PNG image and save image and makes a webp image.

if i want to convert it to webp i will click on a CONVERT TO WEBP image and not on save/download.

alright, googles chrome downloads a png if i want to download a png.


stop telling users what to download


i dont click on save a png file to get a webp image to upload it somewhere again to convert it to png whats wrong with u.


tell me other applications which can handle webp, there is like none.

i wanted the image for nvidias game streaming game cover. its not like nvidia is a small company but still it does NOT support webp .

[Profanity removed by moderator. Please read Mozilla Support rules and guidelines, thanks.]

Geändert am von Chris Ilias

more options

Hi everyone,
cor-el's post was marked as the solution by the person who asked the original question (nekosd43). Your issues may have similar symptoms, but it is likely a different cause/solution. For better help, it would be best to use https://support.mozilla.org/en-US/questions/new where volunteers can get more details about your setup.

In addition, could everyone please read Mozilla Support rules and guidelines? I've had to edit out the personal attacks in earlier posts, thanks.

Because this thread is solved and more people might start using it for their own questions, I'm going to lock it.

  1. 1
  2. 2