Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

I can't enter a website address on my camera and microphone settings.

  • 17 Antworten
  • 3 haben dieses Problem
  • 2095 Aufrufe
  • Letzte Antwort von jscher2000

more options

Thank you for any assistance you can provide. I very much appreciate it. I am able to join a conference on BigBlueButton. However, I cannot activate my microphone or webcam.

I followed the Mozilla instructions for allowing microphone and webcam permission for this site. However, when I enter the web address for the site into the "Settings-Camera Permissions" or "Settings-Microphone" box, and hit "Enter," it will not enter the website.

I'm on a mac ios, and I also followed the Mozilla instructions for changing the camera and microphone permissions in the system preferences>privacy settings, but was unsuccessful there as well.

Again, thank you for any help you can provide.

Arthur

moved from Firefox for iOS to Firefox for Desktop - Andrew

Geändert am von Andrew

Ausgewählte Lösung

This is MacOS X?

Could you try granting permission through one of the following methods:

(A) Check for a prompt at the left end of the address bar

If the site has asked Firefox for camera/microphone permission, there may be an extra icon next to the lock. Click that to see whether you can grant permissions there.

(B) Use the Page Info dialog

While you're on the site, either:

  • Command + i (Windows: Ctrl + i)
  • (menu bar) Tools > Page Info
  • right-click (Mac: Ctrl+click) a blank area of the page > View Page Info

In the Page Info dialog, click the Permissions icon at the top.

On that panel, scroll down to Use the camera and (A) uncheck Use default and (B) click the permission you want to give the site.

Repeat with Use the microphone.

Then you can close this dialog (it saves as you go and there's no save button to click).

Does that work?

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (17)

more options

Ausgewählte Lösung

This is MacOS X?

Could you try granting permission through one of the following methods:

(A) Check for a prompt at the left end of the address bar

If the site has asked Firefox for camera/microphone permission, there may be an extra icon next to the lock. Click that to see whether you can grant permissions there.

(B) Use the Page Info dialog

While you're on the site, either:

  • Command + i (Windows: Ctrl + i)
  • (menu bar) Tools > Page Info
  • right-click (Mac: Ctrl+click) a blank area of the page > View Page Info

In the Page Info dialog, click the Permissions icon at the top.

On that panel, scroll down to Use the camera and (A) uncheck Use default and (B) click the permission you want to give the site.

Repeat with Use the microphone.

Then you can close this dialog (it saves as you go and there's no save button to click).

Does that work?

Geändert am von jscher2000

more options

Dear jscher2000,

Your kind and effective guidance did the trick!

My MacBook runs the latest version of the Catalina OS.

Thank you for taking the time to help me with this vexing issue.

Your assistance and consideration is VERY much appreciated!

Kindest Regards,

Arthur

more options

Did not work for Windows 10. Used the source URL to change permissions to allow video & microphone as suggested in Option A but did not work. Still cannot add my doctor's DOXY.ME software to work. How do I change permissions on camera and microphone? I changed privacy from Strict to Standard with no success.

more options

Hi desmond1, camera and microphone permissions are always granted on a site-by-site basis.

In your Permissions, do you have the site listed as

https://doxy.me

In the site's help page at https://help.doxy.me/en/articles/2427185-allow-access-to-camera-in-firefox they show an example url of

https://yourclinic.doxy.me

so possibly you need a permission for a specific doctor's address, which you might not know without visiting that page.

more options

Howdy, jscher2000!

I appreciate your answer but it still does not tell me how to enter or what is preventing me from entering https://doxy.me/mydoctor into my permissions.

I did utilize something doxy.me provided on the screens as I was signing into their website. Although the top half of the lead box showed connection had been made, the bottom half did not have the option to "X out" of the "Temporarily disconnected" option. This prompted me to go to my Windows 10 settings and turn on my microphone and camera. We were able to see our portion of the video (my Wife and I) but the time frame by then was too long and the Doc opted to call us.

I've tried to enclosed my privacy settings but screen print only allows "bmp" and "support.mozilla.ord" does not allow it or a Word document. If y'all know of how to get a document or "bmp" file to you, let me know. FYI, I always use "Always Use Private Browsing Mode".

Again, your input is greatly appreciated.

God Bless Yall and Stay Safe!

Irish Texan

more options

Hi desmond1, you can't enter sites through the Options page. Did you try method (B):

jscher2000 said

(B) Use the Page Info dialog

While you're on the site, either:
  • Command + i (Windows: Ctrl + i)
  • (menu bar) Tools > Page Info
  • right-click (Mac: Ctrl+click) a blank area of the page > View Page Info
In the Page Info dialog, click the Permissions icon at the top.

On that panel, scroll down to Use the camera and (A) uncheck Use default and (B) click the permission you want to give the site.

Repeat with Use the microphone.

Then you can close this dialog (it saves as you go and there's no save button to click).

If that still doesn't work, perhaps it's not designed to work in Firefox. You might need to try a different browser.

more options

It is possible that the page is using frames to embed content from another domain and that can cause these setting not working properly.

more options

Howdy, cor-el!

Thanks for the response but it's a tad over my head. Are you referring to my privacy selection page on FIrefox or are your referring to the "frames" on the connection with doxy.me?

God Bless y'all for your repy and Stay Safe!

Irish Texan

more options

jscher2000 said

This is MacOS X? Could you try granting permission through one of the following methods: (A) Check for a prompt at the left end of the address bar If the site has asked Firefox for camera/microphone permission, there may be an extra icon next to the lock. Click that to see whether you can grant permissions there. (B) Use the Page Info dialog While you're on the site, either:
  • Command + i (Windows: Ctrl + i)
  • (menu bar) Tools > Page Info
  • right-click (Mac: Ctrl+click) a blank area of the page > View Page Info
I used your steps above to give permissions for the microphone, to be able to use the dictation feature of MS Word online, but I still get an error, that the program does not have access to the microphone. You may try on the page below. below Pls. see the image included. Any help will be appreciated.
more options

If on the current page (domain in the location bar) a page from another domain is embedded that uses the camera and microphone then you would have have to grant permission for that other domain. It can sometimes be difficult to notice that (i)frames are used.

more options

williepabon said

I used your steps above to give permissions for the microphone, to be able to use the dictation feature of MS Word online, but I still get an error, that the program does not have access to the microphone.

Hi williepabon, when I test out the dictation feature on Word online, I am prompted to grant microphone permission and then, somehow, magically, it works. Pretty well. This is Firefox 80 on Windows, if that matters.

When you click the lock icon in the address bar on the page, does the panel that drops down show that Microphone permission has been granted? If so, you could try removing it (click the X) and let the site prompt you to add it again. This may be necessary if you changed input devices from the last time you used the site, for example, between a built-in microphone and a headset microphone.

Note: on the Preferences page, Privacy & Security panel, Permissions section, make sure you haven't blocked microphone requests when you need a site to prompt for permission. (See attached screenshot.)

Actually, now that I re-read the alert from the page, it doesn't ask you to check whether the page has permission, it asks you to check whether Firefox itself has access to the Microphone. That sounds like it could be a MacOS application permission setting. Can you find those?

more options

jscher2000: Thanks for answering so fast. I'm sorry that I didn't indicate that my OS is Ubuntu Linux (64bit) and that my Firefox version is 79. I didn't pay to much attention to it because the dictation feature worked without problems with Google Chrome. But I needed it to work here, since Firefox is my default browser. I also verified your suggestions:

jscher2000 said

When you click the lock icon in the address bar on the page, does the panel that drops down show that Microphone permission has been granted? If so, you could try removing it (click the X) and let the site prompt you to add it again. This may be necessary if you changed input devices from the last time you used the site, for example, between a built-in microphone and a headset microphone. Note: on the Preferences page, Privacy & Security panel, Permissions section, make sure you haven't blocked microphone requests when you need a site to prompt for permission. (See attached screenshot.) Actually, now that I re-read the alert from the page, it doesn't ask you to check whether the page has permission, it asks you to check whether Firefox itself has access to the Microphone. That sounds like it could be a MacOS application permission setting. Can you find those?

But the problem still persist. Maybe, I'll probably have to wait until I get the latest Firefox version from Ubuntu, to see if the problem is solved, but this is not typical. Thanks anyway for your suggestions.

more options

williepabon said

my OS is Ubuntu Linux (64bit) and that my Firefox version is 79.

Does Firefox work with your microphone on other sites?

more options

Are you using Private Browsing mode in case that makes a difference ?

more options

jscher2000 and cor-el:

Firefox works ok on web.whatsapp.com and on Skype, to the best of my knowledge. Also the web cam is recognized by the OS without problems. An to answer cor-el, I'm not using private mode on these tests. Thanks again for your interest.

more options

cor-el said

If on the current page (domain in the location bar) a page from another domain is embedded that uses the camera and microphone then you would have have to grant permission for that other domain. It can sometimes be difficult to notice that (i)frames are used.

I gave permissions (microphone/camera) to this one and to this other, but the problem is still there. I really want to solve this because I want to keep Firefox as my default browser. As I said before, I have no trouble with the Chrome browser.

more options

Hi williepabon, to briefly update you: I was testing on the paid version of Word (Office365/Microsoft365). When I test on the free Word online through OneDrive, I got the same error you did. Microsoft's scripting was a bit too complicated for me to sort out, so I filed a bug report for it yesterday. Hopefully someone will get to the bottom of it. See also: https://support.mozilla.org/questions/1303545