Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Subdirectories in /home/username/ are not showing up

  • 5 Antworten
  • 1 hat dieses Problem
  • 1 Aufruf
  • Letzte Antwort von cor-el

more options

uname -a Linux fir.nuclix 4.19.0-parrot4-28t-amd64 #1 SMP Parrot 4.19.28-2parrot4.28t (2019-04-18) x86_64 GNU/Linux

Note: ParrotOS is based on Debian 9.

Firefox ESR 60.6.1esr (64 bit)

MATE 1.20.5

When I try to browse for a file to upload, or browse for a place to download a file, my /home/username/ directory only shows standard directories like: Desktop, Downloads, Pictures, etc.

I have other subdirectories in my home file, but they do not show up. They used to, but not anymore.

This is not a permissions or ownership issue. The other subdirectories have the same permissions and ownership. Also I have tried changing permissions to 777, nothing works.

uname -a Linux fir.nuclix 4.19.0-parrot4-28t-amd64 #1 SMP Parrot 4.19.28-2parrot4.28t (2019-04-18) x86_64 GNU/Linux Note: ParrotOS is based on Debian 9. Firefox ESR 60.6.1esr (64 bit) MATE 1.20.5 When I try to browse for a file to upload, or browse for a place to download a file, my /home/username/ directory only shows standard directories like: Desktop, Downloads, Pictures, etc. I have other subdirectories in my home file, but they do not show up. They used to, but not anymore. This is not a permissions or ownership issue. The other subdirectories have the same permissions and ownership. Also I have tried changing permissions to 777, nothing works.

Ausgewählte Lösung

I solved the problem. It was something called "firejail" that was install on my system by default.

I did an

  1. apt remove firejail --purge

And that seemed to fix it.

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (5)

more options

/root is a standard first-tier directory in the root directory (as are /bin, /boot, /dev, /etc, /home, /mnt, /sbin and /usr). The root directory is the top level directory on any Unix-like operating system, i.e., the directory that contains all other directories and their subdirectories.

more options

Note that the OP didn't mention the root level, but is talking about its user home directory (/home/<user>/ or ~/).

All standard system directories in the user home directory are hidden directory that start with a '.'. You can probably toggle hidden files via the right-click context menu if there isn't a menu button present.

more options

The subdirectories that are not showing up are not hidden.

/home/userdirectory

  /Books/
  /Desktop/
  /Documents/
  /Downloads/
  /Dropbox/
  /Music/
  /Pictures/
  /Videos/

Of those: "Books" and "Dropbox" are not showing up. The subdirectories are not hidden. The permissions and ownership are the same as the others. But no matter what I do, they do not show up.

Geändert am von walterbyrd

more options

Ausgewählte Lösung

I solved the problem. It was something called "firejail" that was install on my system by default.

I did an

  1. apt remove firejail --purge

And that seemed to fix it.

more options

Firejail is a sandbox application, so it looks that custom directories that you created aren't white listed and may have to be added to the list of allowed paths.