X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

How can I turn of the STUPID nonsense that makes Firefox think a backspace is the same as the back arrow button on the navigation toolbar?

Veröffentlicht

Whenever I am trying to enter text on a webpage [JUST LIKE ENTERING THIS TEXT NOW] if I need to backspace to correct a typo, Firefox randomly decides to interpret the backspace as if I had clicked on the back button on the navigation toolbar! I tried to find out what was wrong and I found that apparently some total nitwit thinks this is a FEATURE. Trust me, it is NOT a feature, it is a BUG!

The weird thing is that sometimes Firefox will let me backspace normally to correct text and other times it will just wildly start jumping back to previous pages.

So, HOW DO I TURN THIS STUPIDITY TOTALLY OFF??

Whenever I am trying to enter text on a webpage [JUST LIKE ENTERING THIS TEXT NOW] if I need to backspace to correct a typo, Firefox randomly decides to interpret the backspace as if I had clicked on the back button on the navigation toolbar! I tried to find out what was wrong and I found that apparently some total nitwit thinks this is a FEATURE. Trust me, it is NOT a feature, it is a BUG! The weird thing is that sometimes Firefox will let me backspace normally to correct text and other times it will just wildly start jumping back to previous pages. So, HOW DO I TURN THIS STUPIDITY TOTALLY OFF??

Ausgewählte Lösung

It shouldn't do "Back" when your cursor is in a text editing field, but if it leaves the field and you press backspace, boom, you went back. I feel your pain and disable it myself. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste back and pause while the list is filtered

(3) Double-click the browser.backspace_action preference and change the value to 2 and click OK.

Two isn't a magic number, any value other than 0 or 1 causes the key to do nothing (outside of a text editing field). See: http://kb.mozillazine.org/Browser.backspace_action

Diese Antwort im Kontext lesen 3

Mehr Details zum System

Installierte Plugins

  • Shockwave Flash 28.0 r0

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Weitere Informationen

jscher2000
  • Top 10 Contributor
8093 Lösungen 66148 Antworten
Veröffentlicht

Ausgewählte Lösung

It shouldn't do "Back" when your cursor is in a text editing field, but if it leaves the field and you press backspace, boom, you went back. I feel your pain and disable it myself. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste back and pause while the list is filtered

(3) Double-click the browser.backspace_action preference and change the value to 2 and click OK.

Two isn't a magic number, any value other than 0 or 1 causes the key to do nothing (outside of a text editing field). See: http://kb.mozillazine.org/Browser.backspace_action

It shouldn't do "Back" when your cursor is in a text editing field, but if it leaves the field and you press backspace, boom, you went back. I feel your pain and disable it myself. Here's how: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''back''' and pause while the list is filtered (3) Double-click the '''browser.backspace_action''' preference and change the value to 2 and click OK. Two isn't a magic number, any value other than 0 or 1 causes the key to do nothing (outside of a text editing field). See: http://kb.mozillazine.org/Browser.backspace_action
Veröffentlicht

Hilfreiche Antwort

Thanks.

I knew that it wasn't doing it all the time, but I could never figure out exactly when it did and didn't do it. It seemed to be doing it when I hit the backspace key several times quickly -- as in backspacing out a word before typing something else. I never thought about where the "cursor" was located because when I'm typing text I really don't care where the mouse pointer is. I have to hands on the keyboard and I usually expect the mouse pointer to stay wherever it was last - which might or might not be at the start of the text box that I am typing in.

This seems like a "feature" that ought to be easier to enable and disable, rather than requiring the Mozilla equivalent of a Windoze Registry Hack.

The "feature" is successfully disabled now -- I've tested it a couple of times while typing this reply and Firefox hasn't tried to leave the page.

Thanks. I knew that it wasn't doing it all the time, but I could never figure out exactly when it did and didn't do it. It seemed to be doing it when I hit the backspace key several times quickly -- as in backspacing out a word before typing something else. I never thought about where the "cursor" was located because when I'm typing text I really don't care where the mouse pointer is. I have to hands on the keyboard and I usually expect the mouse pointer to stay wherever it was last - which might or might not be at the start of the text box that I am typing in. This seems like a "feature" that ought to be easier to enable and disable, rather than requiring the Mozilla equivalent of a Windoze Registry Hack. The "feature" is successfully disabled now -- I've tested it a couple of times while typing this reply and Firefox hasn't tried to leave the page.

Geändert am von curriet