Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

How can I resolve the error code: SSL_ERROR_UNSUPPORTED_VERSION?

  • 5 Antworten
  • 41 haben dieses Problem
  • 50184 Aufrufe
  • Letzte Antwort von philipp

more options

Starting about a week ago, several sites/pages that I've previously visited successfully will no longer load. Most notably, I can no longer get Amazon's "My Cart" page to load. Instead, I get the following message:

    Secure Connection Failed
    An error occurred during a connection to smile.amazon.com. Peer using unsupported version of security protocol. Error code: 
    SSL_ERROR_UNSUPPORTED_VERSION
   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.

Well, I'm not likely to get much attention from Amazon, and the smaller sites are as confused about this as I am.

I've already tried the "no proxy" setting in FF (no joy) and renaming cert8.db and deleting cert_override.txt (also no joy).

My next test is to disable all of the extensions that I've installed in the past month (but I have to restart, so this post comes first--I'll report back in a reply).

Ausgewählte Lösung

hi, please enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for bold preferences starting with security. - right-click and reset those entries to their default values.

Diese Antwort im Kontext lesen 👍 10

Alle Antworten (5)

more options

Disabling the recent extensions had no effect--the error is still occurring.

I know that Mozilla has been making noises for months about forcing the issue with web sites that use older versions of SSL/TLS, so I'm wondering if that's what's going on. But, if so, why am I not seeing any other complaints about this on this forum (or when googling the error)?

And surely Amazon isn't using an old TLS version on their Cart page??!!

more options

Ausgewählte Lösung

hi, please enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for bold preferences starting with security. - right-click and reset those entries to their default values.

more options

I just found this article: https://www.reddit.com/r/firefox/comments/3coba7/firefox_39_completely_breaks_older_sslv3_pages/

However, this doesn't explain why I didn't have this problem until after updating to FF 45 (and maybe not until 45.0.1).

more options

philipp said

hi, please enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for bold preferences starting with security. - right-click and reset those entries to their default values.

That did the trick. I reset the following to their defaults: security.ssl.errorReporting.automatic (from true to false) security.tls.version.min (from 2 to 1)

What puzzles me is that I changed those values well over 2 (3?) years ago--why the problem now?

more options

with your prior configuration you've basically blocked TLS1.0, but that is the only secure protocol that this amazon links is currently providing... maybe you are seeing the issue just now, because their server configuration changed and there were more protocols available before? (i don't think that a recent firefox update would be related to that)