Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

HTML5 Video playback is not working in specific conditions

  • 2 Antworten
  • 3 haben dieses Problem
  • 5 Aufrufe
  • Letzte Antwort von NoGoodby

more options

Playing a specific video on Youtube now results in "An error occurred..." message. I was able to play the video 2 weeks ago. It is only doing this at this video and not of any other video of "The script". I'm using Firefox 40.0.3 for Ubuntu Linux with Flash disabled and use the HTML5 player.

Playback only results in a error message with this particularly video: https://www.youtube.com/watch?v=ho9xM9n2USA


This is what I did so far:

- Enable Flash to see if it can play in Flash: No does not work - Restart with deactivated : does not work - Switch Firefox profile (firefox -p). This would rule out all cookie and plugin issues: no does not work

Meanwhile I can pinpoint this to Firefox for Linux:

- Ubuntu standard Internet browser DOES play the video - The Google Chromium browser in Linux also plays the video - I can play the video using Firefox for Windows.

So, it must be in this version 40.0.3 for Linux.

I use www.youtube.com/html5 to check firefox on how it can playback HTML5 content. It CAN play back:

- HTMLVideoElement - H.264 - WebM VP8

It CANNOT play:

- Media Source Extensions - MSE & H.264 - MSE & WebM VP9

So if I do now the same test on Firefox on Windows where the video plays, 2 of them are positive. "Media Source Extensions" and "MSE & H.264". So one of both must be the cause that it is not working on Firefox on Linux.

Using this information I switched Firefox parameters: http://www.ghacks.net/2014/07/25/enable-mse-h2-64-support-youtube-firefox-right-now/

enter: about:config media.mediasource.enabled > TRUE

Using this I could enable "Media Source Extensions". After switching this I got my video WORKING !!!!

media.mediasource.mp4.enabled (already was true) media.fragmented-mp4.enabled (already was true) media.fragmented-mp4.exposed > TRUE media.fragmented-mp4.ffmpeg.enabled > TRUE media.fragmented-mp4.gmp.enabled > TRUE media.fragmented-mp4.use-blank-decoder (already was false and must be false)

This is a nice solution for me but when is this solved in the standard version? Nobody is working on this bug: Bug 778617 - (MSE) Tracking bug for Media Source Extensions API implementation. New versions of Firefox could flip back the parameters. For now it works, but for how long?

Alle Antworten (2)

more options
more options

No that does not solve the issue.

You posted links to the standard support page with generic solution for issues with plug-ins or flash. This is not Flash related and not even plug-in related.

You can help users if:

- you give information how to switch Firefox parameter regarding this

 issue. This information is more or less already in my description.

- Give information when MSE & H2.64 support is standard available in

  Firefox for Ubuntu Linux. Now it is not.

Looking forward to your answer.