Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

SafeSearch has locked Browser.startup.homepage and I can't reset it.

  • 3 Antworten
  • 3 haben dieses Problem
  • 33 Aufrufe
  • Letzte Antwort von gmoody

more options

Starting up Firefox defaults to safesearch web site. My home page is locked to this site and I can't change it. I've tried the firefox reset, virus removal tools, register edit and can't seem to change the setting. I looked in about:config and see the there is a locked preferences for Browser.Startup.Homepage with the safesearch web site. How can I unlocked this setting?

Alle Antworten (3)

more options

Check for the presence of a mozilla.cfg file in the Firefox program folder to initialize some prefs.

This also involves the presence of a .js (JScript) file, probably in "defaults\pref" folder, that specifies to process this mozilla.cfg file.

If you have .js files apart from the channel-prefs.js file, that sets app.update.channel, in the defaults\pref folder then open this file in an editor like Notepad and please post its content. Also please post the content of the mozilla.cfg file.

There shouldn't be a mozilla.fcg file present unless you've created it yourself to initialize some prefs.

If you have this mozilla.cfg file then best is to do a clean reinstall and delete the Firefox program folder before reinstalling a fresh copy of Firefox. See:

You can find the full version of the current Firefox 34 release in all languages and for all Operating Systems here:

more options

Thank you for responding to my dilemma.

There is a mozilla.cfg file located on my C drive in Program Files(x86)/Mozilla Firefox directory. Also, there is a local-settings.js script that reference the mozilla,cfg file. The script is located in the same directory in \defaults\pref. There is also a channel-prefs.js file located in the same directory that looks normal.

The content of the local-settings.js file is:

// pref("general.config.filename", "mozilla.cfg");

The mozilla.cfg file is not readable so I can't really post it. Additionally, I didn't create the file. I've posted an image in Hex format.

Thanks for providing your help and I look forward to your reply.

more options

gmoody said

Thank you for responding to my dilemma. There is a mozilla.cfg file located on my C drive in Program Files(x86)/Mozilla Firefox directory. Also, there is a local-settings.js script that reference the mozilla,cfg file. The script is located in the same directory in \defaults\pref. There is also a channel-prefs.js file located in the same directory that looks normal. The content of the local-settings.js file is: // pref("general.config.filename", "mozilla.cfg"); The mozilla.cfg file is not readable so I can't really post it. Additionally, I didn't create the file. I've posted an image in Hex format. Thanks for providing your help and I look forward to your reply.
                    • UPDATE ************************

I renamed the mozilla.cfg and local-settings.js file and finally regain control of defining my home page. I think that I finally got rid of that most annoying safesearch crap. Thank you very much for help.