Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

An invasive program that I can't remove from my computer called 'Trovi' has changed what appears on my new tabs, and I can't change them back to my homepage.

  • 2 Antworten
  • 9 haben dieses Problem
  • 1 Aufruf
  • Letzte Antwort von jscher2000

more options

A few programs under the name of 'Trovi' have piggybacked on another file downloaded onto my computer. This program has altered my settings as such that clicking the + to open a new tab opens a page hosted by Trovi- a search engine powered by Bing. I can't find a settings option in my FireFox browser to change my new tab settings- to make them start off on google again. I've used more than one of the recommended programs for finding and removing malware, and the results are beyond infuriating. The programs find the Trovi files, recognize them as malware, appears to let me quarantine them, and then appears to let me delete them. No matter how many times I went through this process, my new tabs still open under the Trovi search page, I still get their cookies, and the programs are still 100% present and active in my computer. Restarting in safe mode after quarantine before 'deleting' the files yields the same results- that is to say, none. I am not very willing to wipe FireFox clean in any manner, as restoring all of my settings, bookmarks and addons would be quite the project.

Alle Antworten (2)

more options

It's possible that the malware is removed but the new tab setting still needs to be restored to a good site. This is hidden and here's how to change it:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter your preferred page:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Press Ctrl+t to open a new tab and verify that it worked. Fixed?

If Firefox ignores the change, one of your extensions may be overriding it. But that's a subject for another post if needed.

more options

Note: based on another thread, you might also need to remove a user.js file which Firefox reads at startup and uses to override the settings change you make in about:config or in the dialogs.

This article describes how to track that down: How to fix preferences that won't save.