X
Tryk her for at gå til webstedets mobilversion.

Supportforum

Why is firefox always connecting to amazon services ?

Skrevet

I start firefox without any open tab, all extensions deactivated.

I can see that it automatically connects to compute.amazonaws.com and cloudfront.net. This is a gross privacy leak !!! Isn't Firefox supposed to be on top of privacy issues ? Is it expected ? Can it be removed ?

I know mozilla's website relies on amazon services (and this is a deep flaw in mozilla's privacy commitment), but there is no reason for Firefox to use it.

I start firefox without any open tab, all extensions deactivated. I can see that it automatically connects to compute.amazonaws.com and cloudfront.net. This is a gross privacy leak !!! Isn't Firefox supposed to be on top of privacy issues ? Is it expected ? Can it be removed ? I know mozilla's website relies on amazon services (and this is a deep flaw in mozilla's privacy commitment), but there is no reason for Firefox to use it.
Citér

Yderligere systemdetaljer

Installerede plugins

  • Shockwave Flash 32.0 r0

Program

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:74.0) Gecko/20100101 Firefox/74.0

Yderligere information

Luk
McCoy
  • Top 10 Contributor
649 løsninger 6142 svar

@ Fffred :

Please ignore the post from the so-called "Firefox Expert" - it's a scam.

@ Fffred : Please ignore the post from the so-called "Firefox Expert" - it's a scam.
Fandt du dette nyttigt?
Citér
jscher2000
  • Top 10 Contributor
8966 løsninger 73474 svar

Hi Fffred, to manage the connections Firefox makes at startup and during operation, please review the steps in the following support article: How to stop Firefox from making automatic connections.

Hi Fffred, to manage the connections Firefox makes at startup and during operation, please review the steps in the following support article: [[How to stop Firefox from making automatic connections]].
Fandt du dette nyttigt?
Citér

Spørgsmålsstiller

@jscher2000 does this mean Firefox, by default, connects to Amazon? What's the point having such advanced anti tracking features if it does provide information to trackers anyways? This is not advertised on Mozilla's website. Instead there is a lot about privacy blabla, which looks increasingly fishy these days

@jscher2000 does this mean Firefox, by default, connects to Amazon? What's the point having such advanced anti tracking features if it does provide information to trackers anyways? This is not advertised on Mozilla's website. Instead there is a lot about privacy blabla, which looks increasingly fishy these days
Fandt du dette nyttigt? 0
Citér
jscher2000
  • Top 10 Contributor
8966 løsninger 73474 svar

Amazon, Google, and Microsoft provide cloud services for a lot of companies. The data related to Mozilla's little bit of the cloud (rented servers) and the data used by the Amazon e-commerce platform are -- to the best of my knowledge -- not connected. They are not connected in Firefox because data is stored under the host name, so the cookies and local storage data/identifiers are completely separate.

Amazon, Google, and Microsoft provide cloud services for a lot of companies. The data related to Mozilla's little bit of the cloud (rented servers) and the data used by the Amazon e-commerce platform are -- to the best of my knowledge -- not connected. They are not connected in Firefox because data is stored under the host name, so the cookies and local storage data/identifiers are completely separate.
Fandt du dette nyttigt?
Citér
cloudbox1 0 løsninger 3 svar

Same issue here. As soon as I open Firefox, even without anything loaded, it connects to a host at *.us-west-2.compute.amazonaws.com (port 443). I understand it might be checking for certificate revocations and such on startup, but in that case the connection would cease in a few minutes. Here it just stays open for good. Even when I'm not doing anything, or computer is idling, the https connection to *.us-west-2.compute.amazonaws.com is always there.

I already have everything off, including telemetry, crash reports, I don't use sync... and I never did. This issue didn't exist until a few weeks ago.

Same issue here. As soon as I open Firefox, even without anything loaded, it connects to a host at *.us-west-2.compute.amazonaws.com (port 443). I understand it might be checking for certificate revocations and such on startup, but in that case the connection would cease in a few minutes. Here it just stays open for good. Even when I'm not doing anything, or computer is idling, the https connection to *.us-west-2.compute.amazonaws.com is always there. I already have everything off, including telemetry, crash reports, I don't use sync... and I never did. This issue didn't exist until a few weeks ago.
Fandt du dette nyttigt?
Citér
jscher2000
  • Top 10 Contributor
8966 løsninger 73474 svar

Nyttigt svar

Hi cloudbox1, are you able to figure out what request Firefox is sending? Knowing the hostname would be useful to adjusting the behavior.

In addition to the connections listed in the support article, Firefox keeps open a channel for web/push notifications. That is mentioned in another article: Web Push notifications in Firefox. That appears to currently use the host name push.services.mozilla.com which is hosted on AWS.

I haven't experimented with completely disabling push notifications (beyond quieting requests as described in that article), but traditionally you would do this:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste push*ena and pause while the list is filtered

(3) Double-click the dom.push.enabled preference to switch the value from true to false

I don't know whether it is necessary or desirable to modify the value of dom.push.connection.enabled -- I don't remember that one from the old days.

If you try that, does it make any difference?

Hi cloudbox1, are you able to figure out what request Firefox is sending? Knowing the hostname would be useful to adjusting the behavior. In addition to the connections listed in [[How to stop Firefox from making automatic connections|the support article]], Firefox keeps open a channel for web/push notifications. That is mentioned in another article: [[Web Push notifications in Firefox]]. That appears to currently use the host name push.services.mozilla.com which is hosted on AWS. I haven't experimented with completely disabling push notifications (beyond quieting requests as described in that article), but traditionally you would do this: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box above the list, type or paste '''push*ena''' and pause while the list is filtered (3) Double-click the '''dom.push.enabled''' preference to switch the value from true to false I don't know whether it is necessary or desirable to modify the value of '''dom.push.connection.enabled''' -- I don't remember that one from the old days. If you try that, does it make any difference?
Fandt du dette nyttigt? 1
Citér
cloudbox1 0 løsninger 3 svar

Thanks, I'll give that a shot, and report back in a day or so. At the moment, they're both Enabled. So this is despite the "official" setting "Block new requests asking to allow notification" is checked?

Thanks, I'll give that a shot, and report back in a day or so. At the moment, they're both Enabled. So this is despite the "official" setting "Block new requests asking to allow notification" is checked?
Fandt du dette nyttigt?
Citér
jscher2000
  • Top 10 Contributor
8966 løsninger 73474 svar

cloudbox1 said

So this is despite the "official" setting "Block new requests asking to allow notification" is checked?

That setting mutes the notification permission icon so sites can't trigger it, but the mechanism for receiving notifications is still set up for sites that you manually add to the permissions list (either through the Page Info > Permissions panel, or on the Options/Preferences page).

''cloudbox1 [[#answer-1302620|said]]'' <blockquote> So this is despite the "official" setting "Block new requests asking to allow notification" is checked? </blockquote> That setting mutes the notification permission icon so sites can't trigger it, but the mechanism for receiving notifications is still set up for sites that you manually add to the permissions list (either through the Page Info > Permissions panel, or on the Options/Preferences page).
Fandt du dette nyttigt?
Citér
cloudbox1 0 løsninger 3 svar

Well, it seems that changing the two toggles to Disabled did the trick. No more unsolicited connections of this kind.

Well, it seems that changing the two toggles to Disabled did the trick. No more unsolicited connections of this kind.
Fandt du dette nyttigt?
Citér
Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.