Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

webgl2 not available after upgrade from 60.9esr to 68.2esr - debian linux - amd hd 4200

more options

With amd HD 4200 graphics chip:

There was no webgl after updating from 60.9esr to 68.2.0esr on debian, and from debian standard repo.

After setting webgl.force-enabled true, webgl1 works, but no webgl2.

WebGL creation failed:

   Refused to create WebGL2 context because of blacklist entry: FEATURE_FAILURE_OLD_FGLRX 

GPU: GPU #1 Active Yes Description Gallium 0.4 on AMD RS880 (DRM 2.49.0 / 4.9.0-11-amd64, LLVM 3.9.1) Vendor ID 0x1002 Device ID 0x9710 Driver Vendor mesa/r600 Driver Version 13.0.6.0 RAM 256MB

The ff tarball from mozilla org extracted to /opt shows same behaviour. It should work, but it seems to be looking for fglrx when open source driver/mesa is installed.

With amd HD 4200 graphics chip: There was no webgl after updating from 60.9esr to 68.2.0esr on debian, and from debian standard repo. After setting webgl.force-enabled true, webgl1 works, but no webgl2. WebGL creation failed: Refused to create WebGL2 context because of blacklist entry: FEATURE_FAILURE_OLD_FGLRX GPU: GPU #1 Active Yes Description Gallium 0.4 on AMD RS880 (DRM 2.49.0 / 4.9.0-11-amd64, LLVM 3.9.1) Vendor ID 0x1002 Device ID 0x9710 Driver Vendor mesa/r600 Driver Version 13.0.6.0 RAM 256MB The ff tarball from mozilla org extracted to /opt shows same behaviour. It should work, but it seems to be looking for fglrx when open source driver/mesa is installed.

Alle svar (4)

more options

basic search everything

more options

Check these entries in about:config

webgl.disabled = False webgl.enable-webgl2 = True webgl.force-enabled = False

more options

'webgl.force-enabled 'is set to true. When set to false, there is no webgl whatsoever. When set to true, webgl 1 works.

These are set as shown (default) webgl.disabled = False webgl.enable-webgl2 = True

more options

Apparently, FEATURE_FAILURE_OLD_FGLRX is a failsafe/failure of the AMD fglrx driver.