Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Connection not secure message for MS Exchange web access

  • 2 replies
  • 1 has this problem
  • 1 view
  • Last reply by cor-el

more options

Getting below warning message while accessing MS Exchange ecp website. I have go daddy SSL certificate installed and it is good in other browsers. attached the error details.

When clicking on certificate icon in the url, below warning pop up Connection not secure this page uses week encryption

Getting below warning message while accessing MS Exchange ecp website. I have go daddy SSL certificate installed and it is good in other browsers. attached the error details. When clicking on certificate icon in the url, below warning pop up Connection not secure this page uses week encryption
Attached screenshots

All Replies (2)

more options
more options

Firefox 71 treats TLS 1.0 and TLS 1.1 as weak and shows the warning that you see. You still can override this in Firefox 71, but Firefox 73 will disable TLS 1.0 and 1.1 (security.tls.version.min = 3).

if you use a bookmark to access a specific page then instead navigate to this page starting with the main page or the sign in page in case there is a problem with this bookmark.

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear