Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Although I am certain I have updated to the most recent version, the Firefox Plugincheck page reports that I have a vulnerable outdated version of Java. How to fix?

  • 1 odgovor
  • 4 ima ovaj problem
  • 4 views
  • Posljednji odgovor poslao Michael Verdi

more options

When I visit https://www.mozilla.org/en-US/plugincheck/ the page reports that the status of my Java Applet Plug-In is "Vulnerable."

After the first time I received the warning, I went to https://support.apple.com/kb/DL1421 and downloaded what I believe is the most recent Java update, 1.6.0_29. I installed that update (apparently successfully, according to the installer), restarted Firefox, cleared my browser cache, and checked again. It did not appear to help.

Additionally, the following is my Java Applet information, copy-pasted from the "About Plugins" page under Help>Troubleshooting Information. I notice that this question page has detected only explanatory text regarding the Java Applet plugin, and not its version number. Therefore:

Java Applet Plug-in

   File: JavaAppletPlugin.plugin
   Version: 14.0.3
   Displays Java applet content, or a placeholder if Java is not installed.

MIME Type Description Suffixes application/x-java-applet;jpi-version=1.6.0_24 Java applet application/x-java-applet;version=1.1.3 Java applet application/x-java-applet Basic Java Applets javaapplet application/x-java-applet;version=1.2.2 Java applet application/x-java-applet;version=1.5 Java applet application/x-java-vm Java applet application/x-java-applet;version=1.3.1 Java applet application/x-java-applet;version=1.3 Java applet application/x-java-applet;version=1.1.2 Java applet application/x-java-applet;version=1.1 Java applet application/x-java-applet;version=1.2.1 Java applet application/x-java-applet;version=1.6 Java applet application/x-java-applet;version=1.4.2 Java applet application/x-java-applet;version=1.4 Java applet application/x-java-applet;version=1.1.1 Java applet application/x-java-applet;version=1.2 Java applet

All Replies (1)

more options

I have the same problem. We definitely have the latest java plugin. I'll file a bug to see if we can fix the plugin check website.