Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Opening devtools make tab unresponsive

  • 1 odgovor
  • 0 ima ovaj problem
  • 26 views
  • Posljednji odgovor poslao zeroknight

more options

I am developing a website (using AstroJS, but i don't think that's the problem) and since yesterday I am experiencing issues when opening devtools. Once I open devtools the whole FF tab becomes unresponsive, I cannot even refresh the page until they are done loading. I can change devtool tabs from 'inspector' to 'console' to 'network' etc but especially 'network' and 'debug' tabs are blank.

I run a 'performance' capture and got these results. In the test I have only opened the devtools and switched to the inspector tab which is unresponsive. The CPU usage is at around 90% however, I don't really know how to read the finding and understand what the problem is.

So anyone that can help me understand what is going on here?

I am developing a website (using AstroJS, but i don't think that's the problem) and since yesterday I am experiencing issues when opening devtools. Once I open devtools the whole FF tab becomes unresponsive, I cannot even refresh the page until they are done loading. I can change devtool tabs from 'inspector' to 'console' to 'network' etc but especially 'network' and 'debug' tabs are blank. I run a 'performance' capture and got [https://profiler.firefox.com/public/rsz6dx1v45m8d4yxyymd9vsx4acw0v1xq2p5g80/calltree/?globalTrackOrder=bc0wa&hiddenGlobalTracks=1w8&hiddenLocalTracksByPid=17464-0w2~15252-0~4872-0~8732-0~12200-013&implementation=js&thread=e&v=10 these] results. In the test I have only opened the devtools and switched to the inspector tab which is unresponsive. The CPU usage is at around 90% however, I don't really know how to read the finding and understand what the problem is. So anyone that can help me understand what is going on here?

Izmjenjeno od strane cor-el

All Replies (1)

more options

Try clearing any breakpoints or debugger statements. Click the "Deactivate breakpoints" button in the top-right corner, next to the gear icon.