Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox doesn't buffering and update screen like youtube sites after updating to firefox 56.0

  • 11 odgovori
  • 2 ima ovaj problem
  • 21 views
  • Posljednji odgovor poslao nekosan0

more options

After I update to firefox 56.0, firefox seems having troubles. I have 2 windows7 machines (64bit OS, 32bit OS). These are in same phenomenon. Chrome in windows and firefox56 in linux-mint, there seems no trouble.

For example, when I open a youtube movie with firefox56 on windows7(64) ....

(1) movie pauses every ~30sec..1min  if the firefox window have the focus

(2) the movie continues playing if "the firefox window lost focus" or "mouse cursor moves over the window" (3) other movie service sites look same.

I think that it seems the firefox have lost events or choked messages. Thus the buffer of movie goes empty, and firefox can't continue show movie. After that, if I make mouse cursor moving on firefox or focusing the another window, buffering restarts and movie continue.

I tried to uninstall firefox and reinstall the older version (55.0), it happenes, too. Very strange!!

I tried on 32bit version windows7, too. In this machine, firefox version was 55.0. It could play youtube fine. But after updating to firefox 56.0, same phenomenon happen.

So it causes with firefox56, I think.


By the way, it seems not only in movie site but also general web site. For example. when I open google map and move mouse cursor away from firefox window (stay in having focus), reading map data might be blocked. And moving mouse cursor on firefox window again, the map continues drawing.

I wonder why it not works in only firefox on windows.

And just now, while I'm writing this issue on this page, text cursor(caret) stops blinking after ~5 seconds after key-in. (it restarts blinking with mouse moving)

Are there anyone faced with the same problem?

Izabrano rješenje

I may have found the cause which avoid communicating of Firefox. This way.

1: re-installing windows7 2: re-installing Firefox 3: re-installing each software I always use with checking whether Firefox works well

When I installed old version of "KH Deskkeeper", Firefox started that strange behavior.

http://www.khsoft.gr.jp/

I uninstall it and install newest version of the app, then Firefox works normally.

The app is a windows software made in japan, it allows us to arrangement desktop icons to favorite places.

(with standard setting,  windows7 makes icons tiling horizontally and vertically)

I like this app and I have used it for years. But I have never updated to newer version.

This is a resident software on windows notification area, and it affects all apps on windows. In similar case, a similar app can cause the phenomenon.

Finally, I have fixed my trouble. It was not caused by malware in my case.

In a similar situation, a resident software can be a suspect.

Pročitajte ovaj odgovor sa objašnjenjem 👍 0

All Replies (11)

more options

Suggest cleaning TEMP files and Folders & Empty your Cache. Do so by hand then use MS Disk Cleanup tool.

Suggest : https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration TRY NO ACCELERATION

And : https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Check Task Manager to see if running Multi-Processor or https://www.ghacks.net/2016/07/22/multi-process-firefox/

And Mozilla experiment, called 'Shield Studies'. Without even knowing it, you may have volunteered for this Mozilla experiment. Would you go to : Options => Privacy & Security => under 'Data Collection and Use' : Did you uncheck : 'Allow Firefox to install and run studies ' or is it checked  ?

To check if you are enrolled in these studies : Type in the address bar about:studies

Any extensions that you see listed there, you can either disable or remove, (at the end of the experiment they will be disabled anyway).

See for further information : https://support.mozilla.org/en-US/kb/shield

Please let us know if this solved your issue or if need further assistance.

more options

Hi Pkshadow. Thank you for your quick response!

I'm now trying some of your suggests step by step. I will report the results later.

And my PC CPUs are

 core2quad (on windows7 64)  ->  troubles
 pentium dual core (on windows7 32)  ->  troubles
 core2duo (on linux mint)  ->  works fine
more options

I have tried those action.

1. trying no acceleration

 --> It doesn't fix the problem.

2. safe mode / firefox reset

--> both don't fix the problem.

3. shiled studies

--> I don't know what information is shared,
     so I can't judge to set "shield studies" checked with my main pc.
      (there are informations on my business in my main pc)
    Thus I set "shield studies" checked with my sub pc ,
      which is pentium dual core/ 2GB dram/ windows7 32bit/
      firefox56.0(32bit)/ radeonHD3400.
      (this phenomenon happen with this pc, too)


I wonder why firefox works fine when the window losts focus,

but not works while it has focus.

It seems not only movie sites but also any general sites.

While firefox is gettting focus and mouse is not moving,

 firefox might not get any data from web-servers,
firefox looks like going into partial-petit-freeze about http access function.

For example, when I access to google map, firefox gets first html file, then tries to get individual map data. But the http access doesn't success (or petit freeze) while firefox has focus.

Therefore movies pause because of data empty when watching movie sites.

But why with firefox in windows7, not with chrome, not in linux mint ?


In older version like 55, 54, 53.... . that might happen , too. Now (firefox56), that always happens in any sites with my pc . But, I ever have watched similar phenomenon in wheather information site below.

https://weather.yahoo.co.jp/weather/zoomradar/

Now: clouds doesn't be displayed while I don't move mouse.

         clouds are displayed while I move mouse on the firefox window.

Before: clouds are displayed normaly, but aren't displayed rarely.

So the things could be getting worse version by version.

more options

I tried to fix it today.

1. updating to latest NVIDIA GT610 driver

 --> it doesn't fix the problem

2. boot windows without non-MSdrivers

--> in this page, I found a similar phenomenon 
    https://support.mozilla.org/en-US/questions/1042299
   So I made windows7 boot with "msconfig"
   Thus I did same, it seems not to fix the problem.
   And the bootloader of my windows7 went broken.
  (I don'T know why)
   I took a lot of time to recover the windows bootloader.

3. try on windows10

 --> I checked with another PC(lap top) which OS is windows10.
     There is not any trouble about playing youtube.
     But I don't know the reason it can play youtube. 
     (OS version? installed software? hardware drivers?)

I think that some non-MSdrivers and startup-programs can be suspects. So I will continue to inspect.

more options

I have checked about the similar phenomenons, and I think that can be a regression.

https://support.mozilla.org/en-US/questions/976293

In this link, they said the bug was already fixed. But I think the bug was regressed.

If it is a regression of the old bug, there seems no way to fix the phenomenon for me.

I will continue trying to find the way to fix, on the other hand, I would like to be fixed if that was a regression.

more options

I have tried do more malware files scanning.

I checked malwares with Malwarebytes' Anti-Malware, AdwCleaner, Anti-rootkit TDSSKiller, ESET Online scanner.

There are no malwares and few adwares in my hdd. Thus I cleaned up these softwares which includes adwares. But, no effects for firefox.

I wonder why it happen only with firefox in windows7? With chrome, it works fine. In windows10 or linux, it seems fine.

more options

Ok please if have not said before and if I have....update your video card drivers. Is a must.

Note that any questions/solutions you find that say they are archived 90+% they will not work. Do not waste your time as the code has had major changes.

Some commands to copy and paste to a file for future reference for all your OS's Please do them Repair System Registry and Files

(FOR DOING Above & Below - WINDOWS All OTHER VERSIONS - Use Search To Find Command Prompt ** Enter CMD.exe to Find COMMAND PROMPT Then Right Click & RUN AS ADMIN)

To run the SFC command use the Windows key + X keyboard shortcut to open the Power User menu and select Command Prompt (Admin). Type "SFC /SCANNOW" (without quotes or copy/paste) and press Enter. For more information on using SFC, please refer to the Microsoft KB: Use the System File Checker tool to repair missing or corrupted system files

Run the Windows Deployment Image Servicing and Management (DISM) and System File Checker (SFC) tools as Administrator. The DISM and SFC tools scan the integrity of the Windows image and all protected system files replaces corrupted, damaged and incorrect versions. (FOR DOING Above & Below - WINDOWS All OTHER VERSIONS - Use Search To Find Command Prompt ** Enter CMD.exe to Find COMMAND PROMPT Then Right Click & RUN AS ADMIN) Type "DISM /Online /Cleanup-Image /RestoreHealth" (without quotes or copy/paste) and press Enter.

Windows 10 To run the DISM command use the Windows key + X keyboard shortcut to open the Power User menu, then select Command Prompt (Admin). Type "DISM /Online /Cleanup-Image /RestoreHealth" (without quotes or copy/paste) and press Enter. While running DISM you may notice the process will appear to pause at 20%. After a few minutes the operation will continue.

Note : SFC fixes files locally using files found on your system. Note : DISM goes up to Microsoft for new ones.

Ok, Uninstall Firefox, reinstall with the Full Version Installer for 56.0.2 https://www.mozilla.org/firefox/all/

Note : Firefox 57 Quantum release date Nov 14th https://www.mozilla.org/en-US/firefox/quantum/ Note : Legacy Extensions will be disabled and or removed.

Please let us know if this solved your issue or if need further assistance.

more options

I tried SFC/DISM on my 3 windows PCs.

[result1] windows7 32bit PC:

  SFC displayed there is no error file.
  Reinstalling FF -> no effect
                 (the phenomenon still exists)

[result2] windows10 64bit laptop PC:

  DISM displayed there is no error file.
 (not reinstall FF because no error and
 FF on this OS works fine from the first)

[result3] windows7 64bit PC:

  SFC displayed there is one error file,
  which is "msvcr80.dll".
  and SFC cannot repair the file.
  I googled about "msvcr80.dll". This file 
  is one of VC++ or .NET2.0 file and used for
  iTunes etc.
  It looks a old file and only for .NET,
  thus I think that it is not related to FF.
  Because FF is a multiplatform software.
  Reinstalled FF -> no effect
                 (the phenomenon still exists)

Conclusion:

SFC/DISM cannot fix the phenomenon.

By the way, Chrome works fine each OSs

but I like firefox because I am a user from Netscape
navigator and I like the bookmark function of it.

The bookmark function of firefox is useful

hence I don't like to use other browser like Chrome.

I am stumped....

more options

Uninstall then delete the Mozilla Firefox folders from C:\Program Files and from C:\Program Files(X86) Reboot, then reinstall https://www.mozilla.org/firefox/all/

All I can think of.

more options

Pkshadow, thank you for your kindness.

I tried uninstall and reinstall firefox on the Windows7 32bit OS machine this way.

0. backup user data with MozBackup 1. uninstall firefox 2. delete "Mozilla" folders from Users folder

     c:Users\++++++++\AppData\Local\
     c:Users\++++++++\AppData\LocalLow\
     c:Users\++++++++\AppData\Roaming\

3. delete "Old Firefox Data" folder from desktop 4. reboot Windows 5. reinstall firefox (clean install)

Result:

   It could not solved my problem.

Incidentally, on first page after reinstall, firefox asked me that there are old firefox data, and whether or not to use the data to reconfig.

Of course, I don't want to use old config data because I want to do clean-install. But firefox looks using a part of the data in it.

I tried to do clean-install. But I can't find the way that firefox doesn't use the old config data. Therefore I gave up today.

I think I have erased all firefox data, but installer looks find some config data from somewhere. Does any one know how to reinstall firefox perfectly? Or where is the old config data? Why firefox ask me whether I want to use the old config data? When and why and who made "Old Firefox Data" on the desktop?

By the way, I think that the trouble occured in the machines I use for long term. I have used two Windows7 machines for years, and these machines have got that trouble. But windows10 and linux machines have no touble, which I don't use long term. Thus firefox could work in wrong way when firefox run with old config data. I think....

more options

Odabrano rješenje

I may have found the cause which avoid communicating of Firefox. This way.

1: re-installing windows7 2: re-installing Firefox 3: re-installing each software I always use with checking whether Firefox works well

When I installed old version of "KH Deskkeeper", Firefox started that strange behavior.

http://www.khsoft.gr.jp/

I uninstall it and install newest version of the app, then Firefox works normally.

The app is a windows software made in japan, it allows us to arrangement desktop icons to favorite places.

(with standard setting,  windows7 makes icons tiling horizontally and vertically)

I like this app and I have used it for years. But I have never updated to newer version.

This is a resident software on windows notification area, and it affects all apps on windows. In similar case, a similar app can cause the phenomenon.

Finally, I have fixed my trouble. It was not caused by malware in my case.

In a similar situation, a resident software can be a suspect.

Izmjenjeno od strane nekosan0