Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

One-click search engine always uses default search engine

  • 3 odgovori
  • 1 ima ovaj problem
  • 537 views
  • Posljednji odgovor poslao richardrv

more options

In the search bar I type the word London and press Enter and get the results of a Google search (my default search engine). I click the magnifying glass to open the search dropdown and click the Wikipedia icon (to perform a search on Wikipedia for the word London). However the results are not from Wikipedia but are the same as my previous search on Google. The only way I can get the search to be performed on Wikipedia is to change Wikipedia to my default search engine. Am I misunderstanding how the one-click search is supposed to work or can you tell me what I need to change to get this to work? Thanks

Priloženi snimci ekrana

Izmjenjeno od strane richardrv

Izabrano rješenje

Using the arrow keys or tabbing to the search engine icon had the same result as clicking the search engine icon directly, no matter what search engine was selected the search was always performed by the default search engine. Running in Safe Mode did solve the problem Disabling Classic Theme Restorer did not solve the problem, however disabling "Tab Control 0.5.5" did solve the problem. In the reviews for this add-on some users mentioned this as a problem. I've removed "Tab Control" as an add-on (even though I did like some of its functionality) as it's no longer maintained. Thanks for your responses.

Pročitajte ovaj odgovor sa objašnjenjem 👍 0

All Replies (3)

more options

You can use the cursor Up and Down keys to cycle through the search engines or use the Tab key to select a search engine other than the default that shows in the second screenshot. That should work. Is it doesn't then check your installed and enabled extensions.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

Try changing Classic Theme Restorer options related to search bar.

more options

Odabrano rješenje

Using the arrow keys or tabbing to the search engine icon had the same result as clicking the search engine icon directly, no matter what search engine was selected the search was always performed by the default search engine. Running in Safe Mode did solve the problem Disabling Classic Theme Restorer did not solve the problem, however disabling "Tab Control 0.5.5" did solve the problem. In the reviews for this add-on some users mentioned this as a problem. I've removed "Tab Control" as an add-on (even though I did like some of its functionality) as it's no longer maintained. Thanks for your responses.