Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Търсене в помощните статии

Избягвайте измамите при поддръжката. Никога няма да ви помолим да се обадите или изпратите SMS на телефонен номер или да споделите лична информация. Моля, докладвайте подозрителна активност на "Докладване за злоупотреба".

Learn More

2 tabs using 6 GB of RAM.

  • 5 отговора
  • 0 имат този проблем
  • 1 изглед
  • Последен отговор от mjwu7185

more options

I have two idle tabs (no videos or other active components) open and according to Task Manager on my PC, it says Firefox is using 6 GB of memory. Unfathomably high number.

The Firefox Process Manager says the GPU (whatever that is) is using 5 GB of memory.

I did all the usual quick fixes (Restart, update, restart PC, refresh, disable add ons, etc.)

Please help. Why is 2 tabs none of which is a video tab using 6 GB of memory?

I have two idle tabs (no videos or other active components) open and according to Task Manager on my PC, it says Firefox is using 6 GB of memory. Unfathomably high number. The Firefox Process Manager says the GPU (whatever that is) is using 5 GB of memory. I did all the usual quick fixes (Restart, update, restart PC, refresh, disable add ons, etc.) Please help. Why is 2 tabs none of which is a video tab using 6 GB of memory?

Всички отговори (5)

more options

Yes, we have some issues with GPUs on Win11. What's your GPU? You can check the name on the about:support page.

more options

GPU is the graphics card. You can try these possible solutions (restart Firefox after applying them)

Make Firefox unload inactive tabs sooner

Disable Accessibility Services

  • Set "accessibility.force_disabled" to 1

Disable Hardware Acceleration and WebRender which try to use more of the GPU compared to the CPU to render pages/videos which can use more RAM in some cases (note that disabling these can shorten battery life on laptops)

  • Settings > search for "Hardware Acceleration" > uncheck "Use recommended performance settings" then uncheck "Use hardware acceleration when available"
  • Set "gfx.webrender.all" to false
more options

I have 2 GPU I see in the about:support Intel(R) UHD Graphics (Active: Yes) NVIDIA GeForce RTX 3060 Laptop GPU (Active: No)

How do I activate my NVIDIA GPU?

more options

mjwu7185 powiedział

How do I activate my NVIDIA GPU?

In your NVidia driver settings. Also it's a good idea to update to 106.0.4 and disable accesibility services (as it was mentioned above).

more options

I had to go to Window's setting under Graphics settings, add Firefox the app to custom set which graphics card that app will use, after that the NVIDIA graphics card (according to about:support) became active. Also updated Firefox. Also set accessibility force disable to 1

The problem seems to be solved! Thank you so much!!!