Search Support

Change your update new default search engine from ASk.com back to Google

  • 8 replies
  • 29 have this problem
  • 42640 views
  • آخر ردّ كتبه LauraLB

more options

I have tried to change ASk.com as my default search engine. Not tab in upper right corner. Large center space on home page. Really don't like ASK and would prefer Google. I have read over your info, tried tutorials. Just don't understand or see how to make change back to Google after update. your help will be appreciated.

Chosen solution

ok, then please try this:

  1. go to firefox > help > troubleshooting information and click on profile folder/show folder. a windows explorer window should open up - in there delete the file named chromeappsstore.sqlite.
  2. then enter about:config into the firefox location bar (confirm the info message in case it shows up) & search for the preference named browser.startup.homepage_override.mstone - right-click and reset that entry to the default value.
  3. restart firefox
Read this answer in context 👍 8

All Replies (8)

more options

hello charlesdic, try to install the search reset addon - it will revert the most common customziations those adware programs do in firefox back to the default: https://addons.mozilla.org/firefox/addon/searchreset/

more options

Did not work. What a mess.

more options

Chosen Solution

ok, then please try this:

  1. go to firefox > help > troubleshooting information and click on profile folder/show folder. a windows explorer window should open up - in there delete the file named chromeappsstore.sqlite.
  2. then enter about:config into the firefox location bar (confirm the info message in case it shows up) & search for the preference named browser.startup.homepage_override.mstone - right-click and reset that entry to the default value.
  3. restart firefox
more options

It worked ! ASK.com must have symbiotic relationship with Mozilla. Thanks for all your help. C

more options

also check in firefox > addons > extensions & remove any entries related to ask.com (toolbars, etc). also go to the windows control panel / programs and remove all toolbars or potentially unwanted software from there to make sure it is really gone...

Remove a toolbar that has taken over your Firefox search or home page

more options

Here is how to do it. Up at the search engine box there is a little arrow to the left of the name of the search company. Click on that arrow and you can change it to a different one that is listed. There is no "default" search engine in firefox. Mine had been changed from google to ask.com. I wanted to change it back to google. VERY SIMPLE. I clicked on the arrow and a list of names to change it to popped up and TA DAH it is now changed back. It SHOULD remember this each time but in case it doesn't just redo it. If you don't see your preferred search company just click manage search engines. and you can search for it if you don't see it. Much easier answer ☺

more options

THIS IS the True MAIN DEFAULT SEARCH PROVIDER FIX for FireFox Navigation:

Type this into search bar on top of the screen: about:config

Confirm to get to the page - (Remember DO NOT CHANGE ANY OTHER VALUES on This PAGE PLEASE!)

There will be another search bar on that page, Type in: keyword.url

Double Click that (it will show as Ask, or Bing, or whatever the search engine is set on)...

You will see a pop up menu stating value... (this is for Google Default Search Engine BTW): Type in: http://www.google.com/search?q=

If you want Bing simply type in: http://www.bing.com/search?q= .., Same for the other providers... ALWAYS keep the value: /search?q=

Confirm... and there is your Google Default Engine until next FireFox update!

The little search on the top right hand side CAN be set to Google BUT you will need to search ONLY in that area... This is for the actual Main Navigation Bar for FireFox!

Hope this helps you all!

Namaste!

Modified by Reality of Sorrow

more options

I had the same problem and successfully RESET Keyword URL. (Which leaves it blank.)

Then I selected Modify and used the following string for the Google default search: http://www.google.com/search?q=

Worked like a charm!