Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Why Do Certain Websites display fonts wrong in Firefox 4?

  • 25 replies
  • 61 have this problem
  • 1997 views
  • آخر ردّ كتبه dionf

more options

Some fonts on certain sites display wrong and I can't seem to fix it. I have clear type turned on. I've attached a link to an screen grab to show my issue. Any help appreciated.

Modified by cor-el

All Replies (20)

more options

I don't see the link anywhere, but you can do the following to resolve the problem.

Go to Tools | Options | Content and in the Fonts & Colors menu, click the Advanced button. Then remove the checkmark where it says "Allow pages to choose their own fonts instead of my selections above".

You can experiment with font styles in the menus on the same page. I've included a screenshot of the way I have my own set up.

more options

Oops forgot to attach! Many thanks for your reply. This does help me see sites batter but the thing is I just want the sites to display how they are meant to look with the fonts the site was made with.

As you can see from the image I have attached, this is not what the default site font is supposed to look like, I checked on another computer to be sure. But when I set my values in options to the same as my other computer (which has firefox 3), and which are in fact the default settings (I had not altered them on either computer) this wrong italicized font is what I get. Happens with other sites too. Any ideas?

more options

The default layout doesn't appear to use italics at all. See screenshot.

Try running Firefox in Troubleshoot Firefox issues using Safe Mode. If it functions properly in that configuration, then one of your add-ons is the culprit.

more options

Thanks for the help, you can see the problem, I just want it to display normally like in your screen grab. I have just tried in safe mode and unfortunately it has made no difference. Still the same odd italic font. Any other ideas?

Modified by Sterz84

more options

Try doing this: Set Minimum Font size

more options

Tried that, still no joy! So odd....The only way I can stop having the illegible italicised fonts appearing is to turn off 'let website chose fonts' and make all defaults sans serif. But then Arial (my chosen default) appears on every site and I don't get the sites actual fonts. Why has this even happened? I never changed any of the defaults before upgrading to firefox 4?

more options

I see that the site is using an Helvetica Neue font:

font-family: "Helvetica Neue",Arial,Helvetica,sans-serif;

There have been many problems reported in the pat caused by older bitmap version of Helvetica fonts. Firefox 4 no longer supports those old versions. So you can check if you have Helvetica and Helvetica Neue installed and remove those fonts.

more options

Thanks again for your help. I do have all the Helvetica fonts, problem is though I need them! I'm a designer....thats part of the reason I need website fonts to display correctly too.

I may have duplicates though. I think in fact I do have duplicates of standard helvetica. Could that be the issue? Perhaps If I get rid of the duplicates?

more options

Use this test to see if the Helvetica font is causing it.

Copy & Paste the code in the location bar and press the Enter key:

data:text/html,
Helvetica<br><font face="Helvetica" size="25">abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ</font><br>
Helvetica Neue<br><font face="Helvetica Neue" size="25">abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ</font>

You may need to look for true type or open type versions of those fonts if the current versions are causing problems.

more options

Hmm well the fonts seem to display completely fine after I do the test. This is very strange. Would re-installing firefox help? I am also getting a bit of hanging when clearing history/cache and temp files etc, takes longer than it should.

more options

I posted elsewhere with the same problem. I'm not a designer, but I'm a cartoonist, and every artist uses fonts...but so do non-artists!! So ridiculous that you expect people to root through all their fonts, just to see sites the way they are designed. WHY does FF 4 even do this???

Instead of asking people to RE-DO their fonts - don't know what the OP ended up doing - this should not even come up in the newest, greatest version of FF!

more options

I'm having the exact same problem with helvetica here, but on another browser. So it seems that the font is the problem. Lucky you to see helvetica light, I'm just gettin helvetica bold everywhere, can't read shiz sometimes D:

more options

I am also experiencing this annoying issue in Firefox 5. On some websites (usbank.com, tweetdeck.com, for example), the primary Helvetica/Arial fonts are being replaced with the first Helvetica font it finds in my Windows fonts folder. As a result, ALL text on the screen was using some ultra wide + bold Helvetica font and near impossible to read.

It took me a while to track it down, but after finding and manually DELETING the wrong Helvetica font being used from the Windows fonts folder, I restarted Firefox, and then the main font was replaced with some Ultra Light variant of Helvetica (the next font in line). I then deleted THAT font, restarted, and now websites are displaying correctly again.

This is pretty annoying, as somehow the two Helvetica fonts I deleted are being automatically reinstalled on my system after a day or two. And when this happens, Firefox starts using the wrong Helvetica fonts again. IE9 and Chrome work fine, BTW. Only in FF is this issue occuring.

Unfortunately I JUST fixed it again otherwise I would provide a picture or two. But I searched for "Firefox using wrong helvetica font" in Google and found this support thread.

I hope this bug gets resolved very soon!

(Using Windows 7 Professional on Core i5 notebook w/4gb ram)

Modified by geminiman7

more options

I spoke too soon. The issue just occurred again and I've attached a couple of before/after screenshots now. Notice how in the first screen shot the font is very wide and pixelated? The 2nd screen shot is after I deleted the next font...

About 10 minutes after posting my last response, I went to USBank.com again and saw that the default font was no longer using standard Helvetica/Arial fonts again. I tracked it down to "Helvetica Neue Extended Thin" and deleted it from the Windows fonts folder. Restarted FF and now it's displaying correctly again.

Firefox keeps changing the standard Helvetica font to the first odd family variant it finds just after a few minutes now it seems.

more options

Try to set the pref gfx.font_rendering.directwrite.use_gdi_table_loading to false on the about:config page.

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

  • Use the Filter bar at to top of the about:config page to locate a preference more easily.
  • Preferences that have been modified show as bold(user set).
  • Preferences can be reset to the default or changed via the right-click context menu.
more options

@cor-el That doesn't seem to help the font replacement issue. It's still replacing the standard fonts with non-standard fonts. Right now, Firefox is now using "Helvetica Helvetica Neue Extended Thin", instead of Helvetica/Arial as defined in the CSS file(s).

As soon as I delete "Helvetica Neue Extended Thin" from my computer, it will display the correct font for a few minutes, and then automatically change it to another strange Helvetica font variant. That's the issue...

more options

go to View Menu -> Zoom -> click on "Reset"

go to View Menu -> Page Style -> select "Basic Page Style"

go to Help Menu -> select "Restart with Add-ons Disabled"

Firefox will close then it will open up with just basic Firefox. You can enable the Add-ons later. Check and tell if its working.

Modified by Hasan

more options

There are other fonts that have been reported to identify themselves as Helvetica.
One is a font with a Chinese name that may appear as the last in the font list.

You can also try:

more options

@mha007 - Performed. Doesn't fix. Does not appear to be a plug-in related issue. Firefox is juts plain loading the wrong fonts.

@ cor-el - Yes, I see that there are many different versions of Helvetica on my system. I am a graphic designer and use different versions of Helvetica, so I deleting every other variant is NOT an option. I originally just deleted a few different versions of Helvetica to test and see if it made a difference--and it did, temporarily (before FF automatically loaded the next incorrect Helvetica font family).

So, it's not a plug-in issue, and deleting every Helvetica/Arial font installed on my computer (except for leaving 1 or 2) is not an option. Something needs to be done programming wise to the Firefox software, I would assume...

Modified by geminiman7

more options

Anyone have a response?

  1. 1
  2. 2