ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox refuses to connect to my NAS admin page

  • 2 (ردّان اثنان)
  • 0 have this problem
  • 132 views
  • آخر ردّ كتبه avdwollenberg

more options

I have a (quite old) Iomega 2 NAS in my local network. I have to connect to the admin page to change some settings, but FF responds with SSL_ERROR_UNSUPPORTED_VERSION, with no option to bypass.

It's my own NAS, in my own local network. How can I bypass this (in this case stupid) restriction? I know it's safe, I know no harm can be done, still I can't get to this page.

I have a (quite old) Iomega 2 NAS in my local network. I have to connect to the admin page to change some settings, but FF responds with SSL_ERROR_UNSUPPORTED_VERSION, with no option to bypass. It's my own NAS, in my own local network. How can I bypass this (in this case stupid) restriction? I know it's safe, I know no harm can be done, still I can't get to this page.

الحل المُختار

I think that refers to the NAS's internal web server not supporting TLS 1.2; Firefox stopped connecting with TLS 1.0 or TLS 1.1 some time ago because they are not considered private any more. But you can reenable them if needed.

Unfortunately, Firefox doesn't have a method to only allow insecure protocols on your internal network, the following change will affect your web browsing as well. But maybe you only need it temporarily and then you can change it back?

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste security.tls.version.min and pause while the list is filtered

(3) Double-click the preference to display an editing field, and change the value to 1 then press Enter or click the blue check mark button to save the change.

To later restore the default value of 3, you can click the Reset button (left arching arrow) at the right end of the row.

If the device is SO OLD that it doesn't even support TLS 1.0, then you probably need to use Internet Explorer 11 to manage it. (Maybe there's a firmware update available.)

Read this answer in context 👍 1

All Replies (2)

more options

الحل المُختار

I think that refers to the NAS's internal web server not supporting TLS 1.2; Firefox stopped connecting with TLS 1.0 or TLS 1.1 some time ago because they are not considered private any more. But you can reenable them if needed.

Unfortunately, Firefox doesn't have a method to only allow insecure protocols on your internal network, the following change will affect your web browsing as well. But maybe you only need it temporarily and then you can change it back?

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste security.tls.version.min and pause while the list is filtered

(3) Double-click the preference to display an editing field, and change the value to 1 then press Enter or click the blue check mark button to save the change.

To later restore the default value of 3, you can click the Reset button (left arching arrow) at the right end of the row.

If the device is SO OLD that it doesn't even support TLS 1.0, then you probably need to use Internet Explorer 11 to manage it. (Maybe there's a firmware update available.)

more options

That did the trick, thank you very much!