ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to stop videos from following you down the page as you scroll down? Check your extensions!

  • 7 ردود
  • 0 have this problem
  • 39 views
  • آخر ردّ كتبه moz2u

more options

FOLLOWUP: Success! It turned out to be an extension called "Enhancer for YouTube". I added that because my add-ons had been wiped out by the update yesterday and forgot that it was a new one I'd never tried before.

Thank you Cor-el for pointing me in the right direction!


This is what transpired before.-----------------------

Using Windows 7. These were suggested. Of course none of them made the slightest difference.

   media.autoplay.default = 5 [0:allow;1:blockAudible;2:Prompt;5:blockAll]
   media.autoplay.blocking_policy = 2
   media.autoplay.allow-extension-background-pages = false
   media.autoplay.block-event.enabled = true 

Does anyone on here understand this stupid video "follow us and block the page for stupid reasons" thing? How can software designers be so brain dead and out of touch with the rest of the planet? I do wonder sometimes.

FOLLOWUP: Success! It turned out to be an extension called "Enhancer for YouTube". I added that because my add-ons had been wiped out by the update yesterday and forgot that it was a new one I'd never tried before. Thank you Cor-el for pointing me in the right direction! ----------------------------------This is what transpired before.----------------------- Using Windows 7. These were suggested. Of course none of them made the slightest difference. media.autoplay.default = 5 [0:allow;1:blockAudible;2:Prompt;5:blockAll] media.autoplay.blocking_policy = 2 media.autoplay.allow-extension-background-pages = false media.autoplay.block-event.enabled = true Does anyone on here understand this stupid video "follow us and block the page for stupid reasons" thing? How can software designers be so brain dead and out of touch with the rest of the planet? I do wonder sometimes.

Modified by moz2u

All Replies (7)

more options

The edit option should be like other forums: Right beside the post. A lot of people are going to miss the "Edit this question" in the upper right hand corner. It is good to be conventional in software/web design. This should be the first rule they learn. It seems to be the last. You see things changed for no reason everywhere.

Modified by moz2u

more options

Hello,

Go to Settings->General->Picture in picture, uncheck it and it should do.

Regards.

more options

It was unchecked.

Modified by moz2u

more options

You can find "Edit this question" under the "Question Tools" menu in the sidebar. For a reply, "Edit" is in the three-dot menu next to a reply.

Opening a fixed mini player automatically is a feature offered by the website and is created via JavaScript if the main player is scrolled out of view. A lot of websites now have a fixed (pop-up) mini player in one the corners once you start playing a video that stays visible if you scroll the page. This website mini player shouldn't be confused with the Firefox PiP (picture-in-picture) feature (you likely see the Firefox PiP icon if you hover the mini player).

You likely need a content blocking extensions to prevent such a player from showing although in some cases blocking media auto-play might work.

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

more options

Dropa said

If the site is doing this then unless there is Addon or 3rd party software to stop this it will follow you regardless it's their site and most likely programmed into the site. You can always contact their site webmaster about this.

Oh please. I use Firefox with YouTube for years and years and the second my browser is updated this happens and its not the browser? You do live in a world of optimism. I don't. Others have mentioned the same problem. Nobody seems to have a solution. I've never seen YouTube do such a stupid thing before. Plus it floats on the LEFT side blocking the comments you are reading below the video window. They do the absolute dumbest thing imaginable then do it in the dumbest way possible.

more options

cor-el said

You can find "Edit this question" under the "Question Tools" menu in the sidebar. For a reply, "Edit" is in the three-dot menu next to a reply. Opening a fixed mini player automatically is a feature offered by the website and is created via JavaScript if the main player is scrolled out of view. A lot of websites now have a fixed (pop-up) mini player in one the corners once you start playing a video that stays visible if you scroll the page. This website mini player shouldn't be confused with the Firefox PiP (picture-in-picture) feature (you likely see the Firefox PiP icon if you hover the mini player). You likely need a content blocking extensions to prevent such a player from showing although in some cases blocking media auto-play might work. Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

Thank you for the Edit Question solution. Things will improve from now on! A link? Every single YouTube video. That's a good link for you. YouTube.com But it doesn't happen on some other sites I tried that display videos. Like news.yahoo.com. Most news sites seem to have a floating player I found.

What kind of extension might work? How do I search for "content blocking"? It could mean anything. I do use an adblocker. Maybe there's other features in it though.

more options

Cor-el Just wanted to thank you for suggesting extensions. Sure enough it was an extension. I've edited my first post.