ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Extensions

  • 18 ردًا
  • 1 has this problem
  • 30 views
  • آخر ردّ كتبه cor-el

more options

Now that extensions are hidden behind the puzzle icon, I can no longer control any of them directly. Case in point: Ghostery. I can't access the app to change its parameters, but can only turn it on and off. Why can't I move these extensions directly to the menu bar, where I can see them and manipulate them?

Now that extensions are hidden behind the puzzle icon, I can no longer control any of them directly. Case in point: Ghostery. I can't access the app to change its parameters, but can only turn it on and off. Why can't I move these extensions directly to the menu bar, where I can see them and manipulate them?

Modified by thos_huxley1

All Replies (18)

more options

The Extensions button (puzzle piece) serves as overflow area for extensions. You can click the gear icon next to the extension or use the right-click context menu to find "Pin to Toolbar" and, on the Navigation Toolbar, "Unpin from Toolbar".

See also this blog post for more info about Manifest V2/V3.

more options

Nothing noted in this "solution" actually exists in my version (Firefox 100.0).

There's no "gear icon" associated with any of my extensions, although there's a generic icon at the top of the extensions page that functionally does nothing. There's no right-click context menu that would enable me to "pin to toolbar." Just doesn't exist.

For each extension all I see is a blue on/off slider button, and the small box with three dots that allows me to remove, report, or manage. Right-clicking on that offers an irrelevant menu.

Again: my extensions have effectively been neutered, and rendered completely uncontrollable--or even visible as separate applications. I can turn them on/off, and that's the limit of their usability. And even that doesn't appear to work.

more options

According to the System Details, you run Firefox 110 (and not 100) and this version has the new Extensions button on the Navigation Toolbar to control your extensions. What I wrote above applies to this new Extensions button and not to the Extensions Manager page (about:addons) like you referenced above.

If you click this Extensions button then you get a list of installed extensions in case you have some, with no extensions installed you will be taken to the about:addons page. Each extension its this list has a gear icon next to it that you can click for more options like explained in the article.

more options

Yes, thank you, I'm running v. 110. Regardless, what you describe simply does not exist on my system.

Your reply, "Each extension in this list has a gear icon next to it that you can click for more options like explained in the article" does not reflect my reality. See attached image.

Clicking the gear icon does not allow access to any extension in any way, so that's out. Clicking on the three-button icon, as noted above, only allows three irrelevant options.

I will appreciate a solution that actually addresses the issue I have described, rather than one that does not.

Thank you.

more options

You still seems to be confused and use the about:addons page. Don't you see the jigsaw puzzle icon Fx109ExtensionsButton at the right end of the Navigation Toolbar?

Fx109ExtensionsButton-Panel
more options

YES, of course.

I click that and get to "Manage Your Extensions," where I can click on Extensions. That takes me to the page mentioned above, where there's only one "gear icon" above the three slider buttons mentioned, which do nothing to assist in managing my extensions.

If I enter "about:addons" in the menu bar, I arrive at the same page.

What you describe simply doesn't exist in my FF version. I'm ready to migrate to Edge, for god's sake.

more options

Don't click "Manage Extensions", just the gear icon on the right side of the addon.

more options

Please view (again!!!) the attached screen shot. The gear icon to the right side of the add-on, to which you and cor-el have referred, DOES NOT EXIST ON MY PLATFORM (110.0).

If it did, I would not be asking this stupid question. Want I want is for my extensions to appear on my menu bar, so I can control them depending on what website I'm visiting. Right now, even turning them "off" from the "manage your extensions" page, does nothing. They appear to be completely inoperative.

Please, SOMEONE, tell me how to resolve my problem.

more options

Let's compare, OK?

LOOK.

more options

.....

Modified by TyDraniu

more options

Right-click an item to open the context menu instead of clicking the gear icon to get more options.

more options

TyDraniu said

You are on the about:addons page. For FSM's sake, this is wrong page. Just click the f* jigsaw icon and nothing else!!!

I know that, but there IS NO OTHER PAGE. There's no effing jigsaw icon to click, just the one illustrated above, and it only executes "tools for all add-ons." If only.

I apologize for what must seem my complete ignorance, but I've looked and clicked everywhere for something that resembles what has been described, in vain. I've even un-installed and reloaded Firefox, to no effect.

From the main page, I click the puzzle icon. That goes to "personalize your firefox." Click "extensions" on the left-hand menu. That directs to the "wrong page" I've described ("manage your extensions"). Right-clicking around here anywhere fails to direct to the "right" page, or grant me access to my extensions. The ONLY thing I can do here is turn them on/off.

What am I doing wrong here? What other options do I have that I'm evidently missing? Right now I'm prepared to install an older version, just to escape this effing annoyance.

more options

cor-el said

Right-click an item to open the context menu instead of clicking the gear icon to get more options.

Been there, done that, repeatedly. Does nothing. What else you got?

more options

This is your fix to put back to normal. I had same issue.

Open about:config, search: extensions.unifiedExtensions.enabled, set to false. Done.

You may have to restart FF, but you will have full control again with toolbar and extensions button. As in you can move puzzle button again.

https://connect.mozilla.org/t5/discussions/version-109-0-new-extensions-icon/m-p/23072

Modified by arugula

more options

Here is a snapshot of what the extensions button looks like.

EDIT : snapshot removed

Modified by Terry

more options

arugula said

Open about:config, search: extensions.unifiedExtensions.enabled, set to false. Done.

Thank you, but that only eliminates the puzzle icon on the menu bar. I still can't land on any settings page that shows gear icons to the right of my extensions.

What next?

more options

Terry said

Here is a snapshot of what the extensions button looks like.

Nothing on my system resembles or executes that pop-up menu.

more options

Make sure you (re)set extensions.unifiedExtensions.enabled to true.

Firefox 109 comes with the new Extensions button as the new way to manage your extensions. You can click the gear icon next to an extension or use the right-click context menu to pin the extension to the toolbar (Pin to Toolbar). To (re)move the extension from the toolbar back to the Extensions button drop-down, you can use "Unpin from Toolbar" in the right-click context menu. If you do not have extensions installed then this button takes you to "Tools -> Add-ons -> Extensions".


The regular overflow area (>>) can only be used for built-in Firefox toolbar buttons as shown in the Customize palette and can no longer be used for extensions. For buttons provided by extensions, the Extensions button drop-down serves as overflow area ("Pin to Toolbar" and "Unpin from Toolbar").


Later this year extensions will move their manifest from Manifest V2 to Manifest V3. With MV3 you have more control on what pages the extension is active (enabled) and you need to allow the MV3 extension for each origin. The new Extensions button provides the UI to manage those permissions and enable the extension and without this button MV3 extensions will be dead (disabled) on all webpages.