ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Linux Firefox and Thunderbird how to set wider scroll bar

  • 8 ردود
  • 0 have this problem
  • 27 views
  • آخر ردّ كتبه Detail

more options

In firefox 108.0.2 I need to have a wider vertical scroll bar, the tiny thin bar is next to impossible to use. Same in Thunderbird 102.6.1 both are in Linux and the published css solutions (a year ago) on mozilla support do not work for these versions

In firefox 108.0.2 I need to have a wider vertical scroll bar, the tiny thin bar is next to impossible to use. Same in Thunderbird 102.6.1 both are in '''Linux''' and the published css solutions (a year ago) on mozilla support do not work for these versions

All Replies (8)

more options

You can look at scrollbar prefs like widget.non-native-theme.* on the about:config page. I have set both widget.non-native-theme.gtk.scrollbar.normal-size and widget.non-native-theme.gtk.scrollbar.thin-size to the same size.

See also: layout.css.scrollbar-width-thin.disabled

more options

This works on my laptop and desktop with normal 1920x1080 resolution but on a high resolution machine like the ASUS Katana (3840x2160) it doesn't. I tried values as high as 150 and didn't see any changes

more options

You can set layout.css.devPixelsPerPx to 1.0 (default is -1) on the about:config page. Adjust its value in 0.1 or 0.05 steps like 1.1 to enlarge or 0.9 to reduce until icons/text looks right. You may need values above 2.0 if you have a high resolution display but make sure not to use values too large or too small.

  • modifying layout.css.devPixelsPerPx affects user interface and webpages (global zoom)

Firefox has a Zoom section in Settings to set the default zoom level for webpages.

  • Settings -> General -> Language and Appearance -> Zoom

You can open the about:config page via the location/address bar. On the warning page, you can click "Accept the Risk and Continue" to open about:config.

more options

Unfortunately, I have already set those and it doesn't affect scrollbars

more options

You can try Firefox from the official Mozilla server if you currently use a version from the repositories of your Linux distribution to see if it behaves differently.

more options

I will try that in the next day or three and report back here with my results

more options

I downloaded firefox and untarred it in /opt Then i set the various about:config values but it still makes no difference. There is something about hi res laptops that kde isn't prepared for it seems

more options

I was extremely vexed by the same problem until I discovered this solution: Windows settings: Accessibility: Visual effects: Always show scrollbars: On. This will make them more visible in FF and in TB.