ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cookies won't delete

  • 6 ردود
  • 1 has this problem
  • 447 views
  • آخر ردّ كتبه FredMcD

more options

I have tried many times and many ways to delete cookies but the little blighters won't delete. I have used the option "manage data" and cleared each one individually, I have tried "remove all' and I have tried clearing all history. I have tried each option many times and have shut down firefox and my mac repeatedly but the cookies won't go. I know it has done something because it logged me out of all my accounts and all the form data and browsing history [which I would rather have kept] is gone....but those rotten cookies are still alive! This must be a bug. I am using Mac Big Sur. Any help would be very much appreciated please! Thanks muchly.

I have tried many times and many ways to delete cookies but the little blighters won't delete. I have used the option "manage data" and cleared each one individually, I have tried "remove all' and I have tried clearing all history. I have tried each option many times and have shut down firefox and my mac repeatedly but the cookies won't go. I know it has done something because it logged me out of all my accounts and all the form data and browsing history [which I would rather have kept] is gone....but those rotten cookies are still alive! This must be a bug. I am using Mac Big Sur. Any help would be very much appreciated please! Thanks muchly.

الحل المُختار

Thank you guys so much for your help. I renamed the Profiles.ini and Install.ini files and set up Firefox again from scratch. Now, when I go to the Privacy / Manage Data, only the Mozilla cookie is there so rejoicing all round!! Hopefully this means that the actual cookie files on my system are gone for good and not buried in the old profiles folder or .ini files. I may have the guts to delete the whole lot of files in the Firefox/Profiles folder but will see how the system runs for now.

Please see the posts from FredMcD and Cor-el above for further info. It does mean I lost my settings [default browser, saved forms, etc] but it was easy to set them up again.

I really appreciate you sharing your knowledge, I have learned a lot from you guys. I will pass on the kind favour. Thanks again and warmest blessings, W

Read this answer in context 👍 0

All Replies (6)

more options

What cookies are you having issues with?

Please explain the problem in detail. What happens? What are the exact error messages?

more options

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

If clearing cookies didn't help then it is possible that the cookies.sqlite file in the Firefox profile folder that stores the cookies got corrupted.

  • rename/remove cookies.sqlite (cookies.sqlite.old) and when present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder with Firefox closed in case cookies.sqlite got corrupted.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

more options

Thank you FredMcD and Cor-el for your quick replies. I have tried the suggestions and learned a great deal, THANK YOU. Those horrid little cookies are still there. Here's more info as suggested by Fred:

There is a long list of cookies when I go to Firefox/Preferences/Privacy/Cookies and Site Data. If I click Manage Data, I get a list of cookies - a few from the list should appear in screenshot althoug it seems to have trouble loading here. I click manage data and have tried "remove all" and they go from the list. Then, to get out, I click "Save Changes". Go back into "Manage Data and there they are again...even if I restart firefox and the restrat the mac umpteen times.

I have tried Corel's suggestions [thanks very much :) ] but the same happens in troubleshooting mode without the extensions. I have also deleted the sqlite files and the whole cookies folder...but i can't fix the problem.

Any other suggestions would be gratefully received if anyone can think of anything else please.

Thanks again and have a nice night :) Wendy P.s. The screenshots just won't load. Some of the cookies are nytimes.com, twitter.com, argos.com,imdb.com - all kinds of things really. P.P.s. I am going to try running clamxav which I do regularly and then try repaing disk permissions.

more options

Use these links to create a new profile. Use this new profile as is. Is the problem still there?

https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible

http://kb.mozillazine.org/Profile_folder_-_Firefox#Navigating_to_the_profile_folder

https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles


Type about:profiles<enter> in the address box.

more options

الحل المُختار

Thank you guys so much for your help. I renamed the Profiles.ini and Install.ini files and set up Firefox again from scratch. Now, when I go to the Privacy / Manage Data, only the Mozilla cookie is there so rejoicing all round!! Hopefully this means that the actual cookie files on my system are gone for good and not buried in the old profiles folder or .ini files. I may have the guts to delete the whole lot of files in the Firefox/Profiles folder but will see how the system runs for now.

Please see the posts from FredMcD and Cor-el above for further info. It does mean I lost my settings [default browser, saved forms, etc] but it was easy to set them up again.

I really appreciate you sharing your knowledge, I have learned a lot from you guys. I will pass on the kind favour. Thanks again and warmest blessings, W

Modified by wendy_pip

more options

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems. Go to that post and click the 'Solved' button to its right.

wendy_pip said

I renamed the Profiles.ini and Install.ini files . . .

This could mean the profiles you had before are still on the hard drive. Firefox won't know they are there. If you want, you can try to recover the data if you want.

Open the profile folder in your file explorer.


https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible

http://kb.mozillazine.org/Profile_folder_-_Firefox#Navigating_to_the_profile_folder

https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles

https://support.mozilla.org/en-US/kb/recover-user-data-missing-after-firefox-update