ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox display font

  • 12 ردًا
  • 1 has this problem
  • 52 views
  • آخر ردّ كتبه Haus

more options

I haven't been able to update Firefox (Mac, desktop) since version 82 because all updates use a font I can't read. Websites are displayed correctly, but bookmarks, most Firefox preferences (including about:config), tab headings and search imputs are as shown in the screenshots.

Today I downloaded version 90 and it's still happening. Please see the screenshots of the Firefox welcome screen, and the font selections in the preferences. The version for the screenshots is a new, clean download using default settings, with no addons or bookmarks.

I don't know if the font is a real language or not.

Attached screenshots

الحل المُختار

You can check in Font Book for font issues like corrupted and duplicate fonts.

Read this answer in context 👍 1

All Replies (12)

more options

Maybe those characters are from a real language, but the way they overprint one another makes no sense.

What I'm going to suggest might be a little difficult if you can't read the screen, so hopefully the following style hack will help:

New Profile Test

This usually takes about 3 minutes...

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

If this page is unintelligible, hack the fonts as follows:

  • Press Shift+F7 to open the Style Editor in the Developer Tools panel (if this shortcut doesn't work, use Command+Shift+i to open the Developer Tools and then click the little Style Editor heading in that panel)
  • In the left column, some style sheets will be listed. If nothing is displayed on the right side, click aboutProfiles.css
  • At the bottom of the panel on the right, press Return a couple times and paste the following:
    body * {font-family: Helvetica, Arial, sans-serif !important;}
  • The fonts in the page should change within a second or so -- any improvement? Example screenshot attached.

Once you can read the page...

Take a quick glance at the page and make a mental note of which Profile has this notation: This is the profile in use and it cannot be deleted. That is your current default profile.

Click the "Create a New Profile" button, then click Next. Assign a name like July2021, ignore the option to relocate the profile folder, and click the Finish button.

Firefox will switch your default profile to the new one, so click the Set as Default Profile button for your regular one to avoid an unwanted surprise at your next startup.

Scroll down to July2021 and click its Launch profile in new browser button.

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system to get a clean test.

Is the user interface readable in the new profile?

When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (July2021 will remain available for future testing.)

Helpful?

more options

By the way, have you tested in Firefox's Safe/Troubleshoot Mode? In that mode, Firefox temporarily hardware acceleration and some other advanced features to help you assess whether these are causing the problem.

If Firefox is running:

You can restart Firefox in Safe/Troubleshoot Mode using either:

  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)

and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

If Firefox is not running:

Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Note: Don't use the Refresh without first reviewing this article to understand what will be deleted: Refresh Firefox - reset add-ons and settings.

Any improvement?

Helpful?

more options

Opening version 90 in troubleshooting mode solves the problem, but turning off troubleshooting mode restores the problem. I don't understand how, as this is running version 90 completely separately from my working version of 82. 90 has no extensions or customisations at all.

I'm going to follow the steps in your first reply and see if that gets down to the problem.

Thank you!

Helpful?

more options

The tips to make the fonts readable in about:profiles wouldn't work. F7 opened an option to use caret browsing. Is there another way to open the Style Editor?

Luckily "create a new profile" is in English, so I made a July2021 profile and switched to it, but it has the same font display problem.

The only changes I've made to the Firefox 90 preferences are disabling hardware acceleration and auto-updates. Everything else is factory default.

Helpful?

more options

I refreshed Firefox 90. See screenshot for the results. At least the font looks happy?

Helpful?

more options

Hmm, Firefox's Safe Mode also disables the new shared font list feature -- this is intended to reduce the overhead of multiple processes, but seems to cause issues for some users.

You can test whether that is relevant with this change:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste gfx.e10s.font-list.shared and pause while the list is filtered

(3) Double-click the preference to switch the value from true to false

I suspect that won't take effect until the next time you quit and restart Firefox.

Helpful?

more options

Alas, it has not solved the problem. I'll revert that value to true, just to prevent confusion later.

This isn't just a version 90 issue for me, by the way - 82 is the last usable version for me. I've experienced the font problem both when updating my current version, and when downloading the newest version and starting from scratch.

Helpful?

more options

You could try to track down the specific change that caused the problem using Mozregression. That's a tool which downloads nightly builds of Firefox in between the last known good release (82.0) and the first bad release (83.0). It does take a good chunk of time because of all the downloads, but as far as spotting the problem, at least that part should be quick.

More info: https://mozilla.github.io/mozregression/quickstart.html

Helpful?

more options

I shall give that a try. Thank you for all your help!

Helpful?

more options

الحل المُختار

You can check in Font Book for font issues like corrupted and duplicate fonts.

Helpful?

more options

"Restore standard fonts" in Font Book worked!

Thank you, cor-el!

Helpful?

more options

It looks like the problem might have been Calibri, which is my favourite font and was the default for Firefox and Mail. It's now gone from Font Book.

(

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.