ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Allow camera and microphone

  • 2 (ردّان اثنان)
  • 1 has this problem
  • 168 views
  • آخر ردّ كتبه jonzn4SUSE

more options

Why do I have to select allow camera and microphone on certain websites each time I access that website? Is there a way to permanently select allowance of a camera and microphone without selecting it every time I access a website?

Why do I have to select allow camera and microphone on certain websites each time I access that website? Is there a way to permanently select allowance of a camera and microphone without selecting it every time I access a website?

All Replies (2)

more options

Hi jmmvp, could you try it this way:

While you are on the site, call up the Page Info dialog using either:

  • Ctrl+i (for Mac, Command+i)
  • right-click a blank area of the page > View Page Info
  • (menu bar) Tools > Page Info

When the dialog comes up, click the Permission icon at the top to show that panel.

Scroll down to "Use the camera" and uncheck the "Use default" box, and then select "Allow". Repeat with "Use the microphone."

Firefox should retain that indefinitely and show it on the Options page, Privacy & Security panel, Permissions section.

If your Firefox is losing permissions between sessions, make sure you don't have one of these situations:

(1) Using automatic private browsing ("Never remember history")

(2) Using "Clear history when Firefox closes" with "Site preferences" selected for clearance (Site preferences includes permissions and zoom levels)

more options

I had the same issue with Google Voice always asking for permission to the mic because I was always clearing the Site Preferences data. Once unchecked that box GV has never asked me again.