ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Bookmarks toolbar is showing incorrect icons for websites.

  • 2 (ردّان اثنان)
  • 1 has this problem
  • 7 views
  • آخر ردّ كتبه cor-el

more options

Bookmarks toolbar is showing incorrect icons for websites. For example, my smile.amazon bookmark shows a Target logo. My Target bookmark shows a Kohl's logo, etc. How can I fix this? I'm running Firefox 76.0 64 bit. Windows 7 Professional

All Replies (2)

more options

It sounds like the file that stores this information may have been damaged. You can erase all of the icons and then Firefox will redownload the icons as you visit the bookmarks.

To remove the icons (known as favicons) you need to do the following:

  1. Go to the about:support page in Firefox.
  2. Press the Open Folder button in the Profile Folder row of the Application Basics table.
  3. Close Firefox.
  4. In the file explorer window that appeared, delete the favicons.sqlite file.
  5. Delete any other variations of this file (like favicons.sqlite-shm or favicons.sqlite-wal, for example.
  6. Open Firefox again.

Your icons will be replaced with the default wireframe sphere icon when you open Firefox, but as you access the bookmarks, Firefox will rebuild the list of icons and they will start to appear again.

If you want all of your icons back at once, some users install the Checkmarks add-on, which automatically opens each bookmark for you and reloads the icon.

Hope this helps.

more options

You can check for problems with the places.sqlite and favicons.sqlite files in the Firefox profile folder.

  • use "Verify Integrity" button on the "Help -> Troubleshooting Information" (about:support) page

If errors are reported with "Verify Integrity", close and restart Firefox and retry.