ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Hello, since some time ago, whenever I click a pdf file, Firefox asks me to download it, instead of previewing it.

  • 12 ردًا
  • 2 have this problem
  • 129 views
  • آخر ردّ كتبه aPersonInNeed

more options

And there is neither file type PDF nor Portable Document Format but only Adobe Acrobat Document but there is no option for FF to preview pdfs

الحل المُختار

Hi, when I open the Options page and change settings and then reload the tab with handlers.json, these are the values I see:

Preview in Firefox => action: 3 Always Ask => action: 2 Save File => action: 0 Use Adobe Acrobat (default) => action: 4

I'm not sure of the best way to access the setting if Portable Document Format does not appear in the dialog. It's possible to edit the file on disk while Firefox is closed in a text editor, but the format is somewhat hard to read.

If you have:

{"application/pdf":{"action":4,"extensions":["pdf"]}

You would change to:

{"application/pdf":{"action":3,"extensions":["pdf"]}

Read this answer in context 👍 1

All Replies (12)

more options

To change the default reader for viewing PDF files in Firefox, follow these steps:

  1. Click the menu button New Fx Menu and click Options (Preferences for Linux or Mac).
  2. In the Options (or Preferences) tab, select the Applications panel.
  3. In the Search field, type PDF to find the Portable Document Format (PDF) entry.
  4. Use the drop-down menu for that entry under the Action column, to select your favorite PDF reader. To view PDF files in Firefox, choose Preview in Firefox.

For more information, see View PDF files in Firefox or choose another viewer.

Did this fix your problem? Please report back to us!

Thank you.

more options

Thanks for the quick reply, but unfortunately, there is neither a file type "PDF" nor "Portable Document Format" but only "Adobe Acrobat Document "--- and there is no option for FF to preview pdfs

more options

HI, so if you Click on that Line Adobe Acrobat Document the button does not allow you to change that to preview or give option to change to Firefox ?

more options
more options

Hmm, I think "Portable Document Format" is one of the built-in, always present, items in that box, so it shouldn't be missing...

Sometimes the settings file that stores download handling preferences becomes corrupted. You can rename the file and have Firefox rebuild it. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit/Quit
  • (menu bar) File > Exit (or Firefox > Quit)

Pause while Firefox finishes its cleanup, then rename handlers.json to something like handlersOLD.json. If you see a file named mimeTypes.rdf, rename that one to mimeTypesOLD.rdf.

Start Firefox back up again, and it should restore the default behavior for PDFs ("Preview in Firefox"). Any improvement?

more options

Pkshadow said

HI, so if you Click on that Line Adobe Acrobat Document the button does not allow you to change that to preview or give option to change to Firefox ?

Well, no, there is no preview available as I wrote. There is a choice that lets you choose a different application -- I tried Firefox and that didn't help, too :-(

Modified by aPersonInNeed

more options

Pkshadow said

There is a how to disable it.

You mean, disabling the screenshots extension could help?

more options

jscher2000 said

Hmm, I think "Portable Document Format" is one of the built-in, always present, items in that box, so it shouldn't be missing... Sometimes the settings file that stores download handling preferences becomes corrupted. You can rename the file and have Firefox rebuild it. Here's how: Open your current Firefox settings (AKA Firefox profile) folder using either
  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter
In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Leaving that window open, switch back to Firefox and Exit, either:
  • "3-bar" menu button > Exit/Quit
  • (menu bar) File > Exit (or Firefox > Quit)
Pause while Firefox finishes its cleanup, then rename handlers.json to something like handlersOLD.json. If you see a file named mimeTypes.rdf, rename that one to mimeTypesOLD.rdf. Start Firefox back up again, and it should restore the default behavior for PDFs ("Preview in Firefox"). Any improvement?

Hi, your solution sounded promising but didn't help either. A new handlers.json was created (no new mime though), but tehre is still no preview available and the file type is still Adobe Acrobat Document and not PDF nor Portable Doc...

See screenshot: these are all available file types...

more options

To see whether application/pdf is in handlers.json, could you drag and drop the file onto an open tab? After a brief delay, Firefox should show a structured view of the file's contents. You can use Find (Ctrl+f) to search for pdf in the page.

more options

Hey, I found application/pdf in that folder but it sais 4 instead of 3. Is that bad? After that under handlers it shows an URL and then extension 0 and pdf.

more options

الحل المُختار

Hi, when I open the Options page and change settings and then reload the tab with handlers.json, these are the values I see:

Preview in Firefox => action: 3 Always Ask => action: 2 Save File => action: 0 Use Adobe Acrobat (default) => action: 4

I'm not sure of the best way to access the setting if Portable Document Format does not appear in the dialog. It's possible to edit the file on disk while Firefox is closed in a text editor, but the format is somewhat hard to read.

If you have:

{"application/pdf":{"action":4,"extensions":["pdf"]}

You would change to:

{"application/pdf":{"action":3,"extensions":["pdf"]}

more options

Hi and thanks a lot! This reply did not '''directly ''' solve the problem, but indirectly it did:

when I started trying your solution, I noticed a button under TROUBLESHOOTING INFORMATION called Clean Up Firefox or the like, I pressed it and Firefox restarted and the problem was solved.

Hallelujah!