ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Unable to Change Settings for Bing.com Searches

  • 4 ردود
  • 2 have this problem
  • 14 views
  • آخر ردّ كتبه Peter C

more options

I use Bing.com as my search engine, but recently it's SafeSearch setting suddenly switch to Strict. I have tried multiple times to set it to anything other than Strict with the setting staying on Strict. I have contacted Microsoft and at their suggestion tried to change this setting on a different browser. I happened to have Chrome on my machine so I when to the setting on Bing on that browser and it was already set to Moderate, so I tried setting it to Off and that worked. Back on Mozilla it was still set to Strict. Please let me know if you have any suggestions or if this is a current problem. Thanks

All Replies (4)

more options

Unfortunately, Microsoft has misconfigured a security feature (OCSP stapling) on their servers which got now cached in your local Firefox installation.

In order to resolve that, please enter about:config into the Firefox address bar (confirm the info message in case it shows up) and search for the preference named security.ssl.enable_ocsp_stapling. Double-click it and change its value to false - this will degrade a security feature in Firefox, so please revisit it in a couple of days again after Microsoft has fixed their stuff and turn it back on again then.

more options

PeterC2 said

I use Bing.com as my search engine, but recently it's SafeSearch setting suddenly switch to Strict. I have tried multiple times to set it to anything other than Strict with the setting staying on Strict.

After you've clicked the setting of your choice,   did you scroll all the way down to the bottom of the page and click 'Save'   ?

more options

Happy112 said

PeterC2 said
I use Bing.com as my search engine, but recently it's SafeSearch setting suddenly switch to Strict. I have tried multiple times to set it to anything other than Strict with the setting staying on Strict.

After you've clicked the setting of your choice,   did you scroll all the way down to the bottom of the page and click 'Save'   ?

Yes I have, I have even tried using the 'Default Settings'.

more options

FredMcD said

Unfortunately, Microsoft has misconfigured a security feature (OCSP stapling) on their servers which got now cached in your local Firefox installation. In order to resolve that, please enter about:config into the Firefox address bar (confirm the info message in case it shows up) and search for the preference named security.ssl.enable_ocsp_stapling. Double-click it and change its value to false - this will degrade a security feature in Firefox, so please revisit it in a couple of days again after Microsoft has fixed their stuff and turn it back on again then.

I have done as you suggested, but the problem persists. Also, since the problem doesn't occur on Chrome, Microsoft doesn't see the problem as a Microsoft one.