X
Tap here to go to the mobile version of the site.

منتدى الدعم

This thread was closed and archived. Please ask a new question if you need help.

Firefox shows black screen when playing YouTube

Posted

I've noticed recently that Firefox stopped playing YouTube videos and showing only black screen where supposed to be a video. So after a lot of research, many people claimed that this is flash player problem. I tried to install earlier version but that didn't change anything. So I uninstalled Firefox and downloaded older, but stable version (34.0.5). And voila! YouTube shows videos again. After a week I noticed that YouTube again shows black screen box. Unintentionally, I opened Revo Uninstall and saw that there's TWO Firefoxes installed - one is that I personally installed and another is newest Firefox 37.0.2. So I uninstalled latest Firefox, but unfortunately it also uninstalled my older version Firefox. So this time I again installed older Firefox (34.0.5) and made that it never look for updates and won't install them. YouTube started to play well. After a few days, again Youtube doesn't show videos, only sound plays, and you can see actual video frames by pointing cursor on video time line. So I checked installed applications and AGAIN found mysteriously installed latest Firefox with the old one. So can anybody help me to stop latest Firefox automatic installation and only leave the old one? Any solution would be very appreciated.

I've noticed recently that Firefox stopped playing YouTube videos and showing only black screen where supposed to be a video. So after a lot of research, many people claimed that this is flash player problem. I tried to install earlier version but that didn't change anything. So I uninstalled Firefox and downloaded older, but stable version (34.0.5). And voila! YouTube shows videos again. After a week I noticed that YouTube again shows black screen box. Unintentionally, I opened Revo Uninstall and saw that there's TWO Firefoxes installed - one is that I personally installed and another is newest Firefox 37.0.2. So I uninstalled latest Firefox, but unfortunately it also uninstalled my older version Firefox. So this time I again installed older Firefox (34.0.5) and made that it never look for updates and won't install them. YouTube started to play well. After a few days, again Youtube doesn't show videos, only sound plays, and you can see actual video frames by pointing cursor on video time line. So I checked installed applications and AGAIN found mysteriously installed latest Firefox with the old one. So can anybody help me to stop latest Firefox automatic installation and only leave the old one? Any solution would be very appreciated.

Chosen solution

YouTube has switched Firefox users from the Flash player to the HTML5 player by default. You usually can distinguish by right-clicking the player and looking at the last item on the context menu that pops up. Or if you check this page, can you confirm that you have been switched?

https://www.youtube.com/html5

As a temporary workaround, there are a couple of extension to force Flash on YouTube for users who find that the HTML5 player is not working for them (or whose downloaders only work with Flash). For example:

But... with Windows 7, you really should be able to use the HTML5 player on YouTube, so it would be ideal to try to debug this problem if you are interested in experimenting a bit.

Read this answer in context 8

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.45.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft Lync
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 18.0 d0
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.3.133
  • Unity Player 4.6.1f1

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0

More Information

jscher2000
  • Top 10 Contributor
8758 solutions 71665 answers

Chosen Solution

YouTube has switched Firefox users from the Flash player to the HTML5 player by default. You usually can distinguish by right-clicking the player and looking at the last item on the context menu that pops up. Or if you check this page, can you confirm that you have been switched?

https://www.youtube.com/html5

As a temporary workaround, there are a couple of extension to force Flash on YouTube for users who find that the HTML5 player is not working for them (or whose downloaders only work with Flash). For example:

But... with Windows 7, you really should be able to use the HTML5 player on YouTube, so it would be ideal to try to debug this problem if you are interested in experimenting a bit.

YouTube has switched Firefox users from the Flash player to the HTML5 player by default. You usually can distinguish by right-clicking the player and looking at the last item on the context menu that pops up. Or if you check this page, can you confirm that you have been switched? https://www.youtube.com/html5 As a temporary workaround, there are a couple of extension to force Flash on YouTube for users who find that the HTML5 player is not working for them (or whose downloaders only work with Flash). For example: * https://addons.mozilla.org/firefox/addon/youtube-flash-video-player/ But... with Windows 7, you really should be able to use the HTML5 player on YouTube, so it would be ideal to try to debug this problem if you are interested in experimenting a bit.

Question owner

Thank you very much! It solved my problem.

Thank you very much! It solved my problem.
ClzwldsFF 0 solutions 4 answers

I was having similar problem. Win7 pro 64. Tried lots of stuff to no avail. Had been adding many filters on adblock on zerohedge to try and block all the crap. Max keiser.com wouldn't play, sound but black screen. Newly loaded firefox 41.0.1. (separate issue)I would caution to take a look at the new cookies retention. It has changed to clear all cookies at close of FF. So here was my cure. Start/control panel/all control panel items/FlashPlayer open it and on the menu bar go to advanced then look down to trusted location settings clk it. I had the black screen of Max Keiser.com playing so I just copied the address and pasted it in the add site/website domain then clk confirm and close. Rebooted and all's good. Hope that helps some cause it's such a pain as the barrage of crap that is being thrown at us. Trying to put up a defense and then overriding the programs in the process.

I was having similar problem. Win7 pro 64. Tried lots of stuff to no avail. Had been adding many filters on adblock on zerohedge to try and block all the crap. Max keiser.com wouldn't play, sound but black screen. Newly loaded firefox 41.0.1. (separate issue)I would caution to take a look at the new cookies retention. It has changed to clear all cookies at close of FF. So here was my cure. Start/control panel/all control panel items/FlashPlayer open it and on the menu bar go to advanced then look down to trusted location settings clk it. I had the black screen of Max Keiser.com playing so I just copied the address and pasted it in the add site/website domain then clk confirm and close. Rebooted and all's good. Hope that helps some cause it's such a pain as the barrage of crap that is being thrown at us. Trying to put up a defense and then overriding the programs in the process.
cor-el
  • Top 10 Contributor
  • Moderator
17528 solutions 158481 answers

(locking thread because of age - c)

''(locking thread because of age - c)''

Modified by cor-el