Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox won't open email links after update to version 32

  • 52 replies
  • 81 have this problem
  • 5620 views
  • آخر ردّ كتبه Justin

more options

I just updated to Firefox 32. When I have FF open but hidden in my Dock on my Mac 10.6.8 it will not open links from my email in Outlook 2011 for Mac. All it will do is unhide Firefox from my dock. Once FF is visible and I click the same link in my email it will open a new tab to that web page. If FF is completely closed and I click a link in an email it will launch FF and open the web page. Only when FF is already open but "Hiding" in my Dock will it not open a new tab with the web page when I click a link from email. I didn't have this problem before the update.

FYI, Firefox is my default browser. I opened Safari and have FF listed as my default browser too. When I did the update I did a brand new download and install.

Chosen solution

Hi Justin, thank you for keeping an eye on this. It is fairly common for someone to request an uplift of the fix to the aurora version (35), and also to the beta version (34) if there is enough time for testing. Not sure whose responsibility it is to propose that.

Read this answer in context 👍 2

All Replies (20)

more options

I use Outlook as my email client on my MAC and since the Firefox update, I cannot open hyperlinks in emails at all. The hyperlinks will open in Safari, but I prefer using Firefox and have it set as my default browzer.

Please fix this. It's truly annoying not to be able to open things! Or tell me how to fix it. Thanks.

more options

Hi, In the past the work around for this is to change the default browser on the operating system then back to Firefox.

However it sounds like @igbirchall already tried this.

more options

Just updated to 32.0.1 and still have the same problem.

more options

Just updated to 32.0.2 and still have the same problem.

more options

Like you I was suffering with this incredibly annoying bug but the following seems to have resolved it at last:

1) In Safari, set Safari as the default browser in settings. 2) Restart the computer 3) Open Firefox and when it asks if you'd like to set it as the default browser choose "yes".

I'm on 32.0.2 and this seems to have finally solved the problem. It hasn't failed to open a link yet. Fingers crossed that it will continue working.

more options

I had done all that before, and it still didn't work.

However, with the update to 32.0.2 Thursday, it is resolved without my having to do anything else. Thank goodness!

more options

Well, I was just about to post an update, because although it was working absolutely perfectly for me after applying the steps I listed above, it has started to occasionally bring up Firefox without navigating to the link again. Specifically, when I select text with PopClip and use the Google Translate plugin from Airmail, it will fail about 75% of the time. However, it is still much improved from before.

This is with 32.0.2.

I never experienced this problem before upgrading to Firefox 32.

Modified by cdanr

more options

Now, it started doing it again. My only fix so far is to quit Firefox and then click the link. It will open in a new tab like before, and then other links will open for a while, and then it stops doing it again.

This is really stupid, Firefox. It ought to be an easy fix. Please.

more options

Thanks for the input cdanr but it didn't resolve the problem for me.

more options

As mentioned, it apparently didn't 100% resolve the problem for me either, jam4jah. I'm sorry to hear it didn't help you at all. It has seemed to almost resolve it for me. I still get the unopened link on occasion.

I hope whatever Mozilla changed to create this problem, they fix in the next revision because it is a highly annoying bug.

more options

I seem to have exactly the same problem as the OP. Tried the resetting-the-default-browser trick, but it did nothing. Happens in Safe Mode also. Quitting FF and restarting helps for a short time, but FF immediately starts failing to open links. Clicking a link in another application, for instance an email program, will bring FF to the front, but then nothing else happens. FF will always open a link one time after a restart, but then usually fails after that initial success. Occasionally, when a tab is already open, FF will succeed in opening the link, but not always.

The only seemingly reliable method I've found to get FF to open links is to close all tabs, then click once in the address field, then hide FF. At that point, if I am in another application I can click on a link and FF will open it correctly.

All of my problems seemed to start with FF32 - at least that's when I noticed it. As mentioned, the problem occurs no matter whether I'm running extensions or running FF in Safe Mode.

Modified by younkint

more options
more options

Thanks, Justin. It's good to know the bug is known to Mozillas and as critical as it is, I'm hoping to see it resolved by the next update.

more options

Thanks Justin!

more options

Thanks for submitting the bug reports. Let's hope there's a solution before too long. I am especially concerned when the problem still exists running FF in Safe Mode.

more options

This is NOT fixed by today's 32.0.3 update. This bug is becoming highly annoying. I may be forced to switch back to Chrome again until Mozilla sees fit to fix it. I was hoping it would be fixed with this most recent revision.

more options

After applying the version 32.0.3 update, I find no change in Firefox's inability to open links. This failure happens even running in Safe Mode.

When working between Firefox and other applications having hypertext links (or even the Finder), this is really slowing me down. Other browsers are not affected.

I'm probably going to have to forgo the superb customization abilities of FF and use another browser just to get some work finished.

more options

Firefox 32.0.3 is purely a security update.

It does not appear that work has started on those bugs yet.

Is this a fair summary of what is happening?

(1) Firefox closed: external link will start Firefox and navigate to the page.

(2) Firefox open, not minimized to the dock: external link will activate Firefox and... usually navigate to the page? sometimes display only a blank tab?

(3) Firefox open, hidden in the dock: external link will activate Firefox but... not navigate to the page or display a blank tab.

(As a Windows user, I personally have zero idea how external links work on MacOSX)

more options

jscher2000 -

I will answer for myself; others may see variations.

(1) True, most of the time ...probably 90%.

(2) I wouldn't use the word, "...usually" in regard to navigating to the page. I doubt I'm seeing 50% in this case. As time goes by, it seems I'm getting fewer blank tabs; rather getting nothing at all, except FF coming to the foreground. Restarting FF helps for a very short time - sometimes.

(3) Mostly true. Sometimes it works. This is the thing: there seems to be some method to cause FF to mostly behave correctly. I've thought I had it figured out a few times, but I'm not quite there. Sometimes having an active tab (with a page loaded) and then opening a blank tab will allow a link to open. This seems to be somewhat dependent upon whether FF is "hidden" or not. This much I can say: if FF is hidden and has only a blank tab, clicking on a link (anywhere but in FF) will fail at least 80% of the time, the only response being that FF is brought to the foreground.

You mentioned that you have "...zero idea how external links work on MacOSX." If you mean the code in the background, that is, the programming, then neither do I. However, as a user of both OS X and Windows, I would say that both systems work identically. If you click on a hyperlink in a Windows Outlook email message, it should open in the default browser. If you happened to have on the Windows desktop a shortcut to a web location, it should do the same. When we are doing this in OS X, with FF as the default browser, FF does come to the front, but then - nothing. Usually.

Edit: Running OS X 10.9.5; FF 32.0.3.

Modified by younkint

more options

jscher2000 -

Yes, that is my situation on OSX 10.6.8.

In scenario (2) When FF is open and not hidden FF will navigate the link in my email to a new tab. No blank tabs ever appear.

  1. 1
  2. 2
  3. 3