Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Hierdie gesprek is in die argief. Vra asseblief 'n nuwe vraag as jy hulp nodig het.

Firefox refreshing more often on back button with v97

  • 4 antwoorde
  • 1 het hierdie probleem
  • 24 views
  • Laaste antwoord deur equilter

more options

Hitting the back button a few times used to load the cached version of the pages, instead of reloading the pages. However with v97, Firefox is much more aggressive about reloading and refreshing when you hit the back button to go back a few pages.

I've tried setting browser.cache.check_doc_frequency to 2 (Never check for a new version - always load the page from cache), but this has the undesirable side effect that if you go click a link in the browser to a page that was cached, the cached content comes up, instead of the latest.

I've also tried settings with browser.sessionhistory.max_total_viewers, but that doesn't seem to work either.

Please advise.

Hitting the back button a few times used to load the cached version of the pages, instead of reloading the pages. However with v97, Firefox is much more aggressive about reloading and refreshing when you hit the back button to go back a few pages. I've tried setting browser.cache.check_doc_frequency to 2 (Never check for a new version - always load the page from cache), but this has the undesirable side effect that if you go click a link in the browser to a page that was cached, the cached content comes up, instead of the latest. I've also tried settings with browser.sessionhistory.max_total_viewers, but that doesn't seem to work either. Please advise.

All Replies (4)

more options

That's correct. Since 97, hitting the back button invokes the onload event. I don't think we can do anything about it.

more options

Thank you for your reply. That's really too bad. This presents significant problems when editing content, and then going back, in that the content then gets revered to a previous state.

Is there any possibility of a variable that could be adjusted to avoid the 'onload event' with the back button?

more options

For now you can turn off Fission (fission.autostart=false in about:config) and restart the browser. But it won't work in the near future.

more options

Thanks for the tip. That's also too bad that this fix won't work for very long. Surely there must be another way?