Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox not auto filling forms like it used to...

  • 1 baphendule
  • 0 zinale nkinga
  • 28 views
  • Igcine ukuphendulwa ngu cor-el

more options

Firefox used to auto fill forms for me but lately it does not. On the rare occasion that it does (for one web site), it fills in one field at a time, not all at once like it used to. It does not fill in my address either.

I tried the usual troubleshooting without success. I went to settings, privacy & security, passwords, and made sure "fill usernames and passwords automatically" was checked. I went to the history section and made sure "remember form and search history" was checked. I went to the custom settings for history section and made sure that Firefox does not clear "form & search history" when it closes. For some reason,(I am in the US) I don't have a "forms and auto fill" section to scroll down too as some users suggest, nor do I have the "auto fill address" box to check or uncheck. Nor do I have a "saved addresses" button to check or uncheck or where I can supposedly add, edit, or delete an address.

I am running windows 11 and use Malewarebytes for my antivirus, although I can find no settings in the Malwarebytes suite that would impact Firefox's ability to auto fill forms. Any suggestions??

Firefox used to auto fill forms for me but lately it does not. On the rare occasion that it does (for one web site), it fills in one field at a time, not all at once like it used to. It does not fill in my address either. I tried the usual troubleshooting without success. I went to settings, privacy & security, passwords, and made sure "fill usernames and passwords automatically" was checked. I went to the history section and made sure "remember form and search history" was checked. I went to the custom settings for history section and made sure that Firefox does not clear "form & search history" when it closes. For some reason,(I am in the US) I don't have a "forms and auto fill" section to scroll down too as some users suggest, nor do I have the "auto fill address" box to check or uncheck. Nor do I have a "saved addresses" button to check or uncheck or where I can supposedly add, edit, or delete an address. I am running windows 11 and use Malewarebytes for my antivirus, although I can find no settings in the Malwarebytes suite that would impact Firefox's ability to auto fill forms. Any suggestions??

All Replies (1)

more options

Does a form entry get filled if you use the tab key to go to the next field ? Does this only happen with filling username and password ?

Are you using extensions that deal with filling forms ?

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

Boot the computer in Windows Safe Mode with network support to see if that has effect.

You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works, you can transfer files from a previously used profile to the new profile, but be careful not to copy corrupted files to avoid carrying over problems.

Helpful?

Buza umbuzo

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.